Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Linux Mint Debian

Eclipse 3.5.2

Anytime I save it gets stuck on 66%

Need to know how to diagnose or fix the issue

share|improve this question
up vote 2 down vote accepted

Check your workspace log for errors:

less workspace/.metadata/.log

Or tail while saving:

tail -f workspace/.metadata/.log
share|improve this answer
    
This was a great idea, though no new logs came up while saving – Seth Hikari Apr 12 '11 at 19:13
    
try starting eclipse from the command line and see if it outputs any errors to the terminal – sreimer Apr 12 '11 at 19:18
    
No errors were reported and I tried using -clean command, but did not help – Seth Hikari Apr 12 '11 at 19:27
    
Removed build automatically fixed the issue. – Seth Hikari Apr 12 '11 at 19:44
    
problem was the time it took to build a large shared library – Seth Hikari Apr 16 '11 at 18:52

One way is to rename .metadata/.plugins/org.eclipse.ui.workbench/workbench.xml to workbench.xml.bak. This basically wipes the workbench state. After starting eclipse it seems to have stopped from this condition of hanging on cleaning/building the workspace.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .