Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Windows XP SP3. I am using COMMAND.COM (not CMD). Using CMD is NOT an option in this case. I am trying to figure out how to change to a directory when there is a space in the directory name. The cd /? was useless.... Here is what I have done so far:

START > RUN...> COMMAND.COM

Microsoft(R) Windows DOS
(C)Copyright Microsoft Corp 1990-2001.

C:\>cd Documents and Settings
Too many parameters - and

C:\>cd "Documents and Settings"
Parameter format not correct -  "Documents

C:\>cd Documents\ and\ Settings
Too many parameters - and\

C:\>cd "Documents\ and\ Settings"
Parameter format not correct -  "Documents\

C:\>cd\Documents and Settings
Too many parameters - and

C:\>cd"\Documents\ and\ Settings"
Parameter format not correct - "\Documents\

I am not sure what else to try. Tab-completion does not work either. I'm sure this is a simple syntax error that I cannot find.

share|improve this question

migrated from stackoverflow.com Apr 13 '11 at 0:47

This question came from our site for professional and enthusiast programmers.

up vote 9 down vote accepted

If you are using command.com, you'll have to use the 8.3 filename version of the file/directory name. In this case, it's probably DOCUME~1.

C:\>cd docume~1

C:\DOCUME~1>

I'm curious why you have to use command.com.

share|improve this answer
    
Thank you for the link! The dir /x came in very handy. I needed to hyperlink the file with a space in the directory name into a closed (non-externally networked) wiki. The wiki does not support spaces in the path name, so I knew going with classic 8.3 would forcefully give me the path name without spaces. – user76345 Apr 13 '11 at 16:49
    
(And I could not upload the file to the wiki) – user76345 Apr 13 '11 at 17:06

cd Docume~1
Works as command.com support naming with a max of 8 characters

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .