Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 7 Home Premium x64, Service Pack 1.

My mouse is a Logitech MX620 Cordless Laser Mouse, driver provided by Logitech: Logitech HID-compliant Cordless Mouse, version 5.20.12.0 (8/24/2010). SetPoint control center is version 6.20.60, driver version 5.20.51.

Now that the technical details are out of the way, here is my story: my computer came with Vista x86, and everything worked fine. I bought the OEM Windows install listed above and did a fresh install on a blank hard drive (i.e. not an upgrade.)

Now my mouse wheel is acting wonky. It scrolls just fine for the most part, but is super-sensitive when it comes to scrolling a tiny fraction, such as when I press it to use it as a middle button. Same hardware as with Vista, but obviously different OS and drivers (using x64 SetPoint and drivers, updated versions).

Again, it scrolls normally, it is just super-sensitive when moving it a tiny bit. If I go to middle-click to open a link in a new tab, the mouse will scroll the link out from underneath my cursor. If I scroll to the top of a page to click a navigation link, it might scroll back down one unit.

When I google or search StackExchange for help, everything comes up with "my mouse doesn't scroll" or "it scrolls too little/too far." My problem is it scrolls fine for normal scrolling, but if I touch the wheel a tiny bit, it will scroll when I don't think it should (and it didn't under Vista).

One other note -- I do have a "microgear" switch under the mouse that makes it "click" when I scroll, but that doesn't affect my problem. The amount of the wheel movement that is undesired is under the "gear threshold" or whatever of the mouse.

Essentially, I want to have a threshold where if I move the mouse wheel less than that amount, it does nothing. This is apparently how Vista handled it, but Windows 7 does not.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I had the same issue with my mouse (also with a button to toggle spin/ratchet mode). In my case, it was the mechanism that handled the ratchet mode wearing out. I was able to fix it a few times by taking apart the mouse and fiddling with the wheel. Eventually I had to buy a new mouse.

share|improve this answer
    
I thought about trying to take it apart, but it has no screws that I can see. It appears that it clicked together and won't come back apart. But it worked fine in Vista, and in a single day didn't work fine in Win7. That smells strongly of some OS-level difference, I just don't know what. –  Snowman Apr 13 '11 at 1:58
    
Sorry about the late response: turns out that buying a new mouse fixed it. Must have been one incredible coincidence that the mouse started going senile at the same time I installed Windows 7. –  Snowman Nov 12 '11 at 5:26

For the record: I also have an MX620 and experienced the same issue in my win7 setup. It is not a hardware issue. You can verify this by terminating the SetPoint software (Right-click tray icon -> Exit) which will disable all tweaks.

For most applications, disabling "Smooth Scrolling" in the setpoint config is the solution. I also uninstall any browser extension added by the setpoint installer.

However, I have the impression that Logitech added some program specific tweaks for Microsoft Office, Adobe reader and the like. From time to time I stumble upon a program where the extreme sensitivity is back and even moving the mouse triggers the scroll wheel. As you say, switching the microgear has no effect on this over-sensitivity.

In any case, upgrade your drivers regularly, as Logitech Support often suggests this as the solution for scroll related issues: http://goo.gl/PBLy8E

share|improve this answer
    
In my case it was the hardware, and swapping hardware confirmed. New mouse, no problem. Same mouse different computer, same problem. In the past two years I have been using a different mouse without the problem in my original question. Your answer may be appropriate for some who google this question, but in my case, it really was hardware. –  Snowman Dec 14 '13 at 5:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.