Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Drobo that I use as an external hard drive. I want to use this disk only for data and I don't want Windows to use it for anything else. But sometimes, when I do something in a program, the Drobo has to awaken and the computer hangs for 5-10s. This is very annoying since sometimes the programs that hang don't even have to access files on the Drobo.

How can I tell Windows not to use a hard drive for anything system related?

Also I already disabled hard drive sleep in the power management settings.

share|improve this question

5 Answers 5

up vote 1 down vote accepted

I don't think it's possible to do that, neither to avoid the drobo to go in standby. However, you could create yourself a batchfile which will simulate a writing on your hard drive in a scheduled task to reset the device's idle time OR create a service/app that will do the same.

Not sure it will works but it's worth a try.

share|improve this answer
    
Made a very simple batch file outputing something in a file and running with the task scheduler every 5 minutes. We'll see if this helps. –  EtienneT Apr 13 '11 at 17:36
    
The problem didn't happen again since I made this script! Thanks! –  EtienneT Apr 22 '11 at 13:32
    
You're welcome. Thank you for the feedback! –  P-L Apr 27 '11 at 18:04

In win7 and win8 you can do the following:

1. press windows + r, to open the run window
2. Type power options into the run window, and open it.
3. In power options, under "select a power plan" click change plan settings
4. A new window pops up, at the bottom click Change advanced power settings
5. A new window with lots of options will open, pick Hard Disk->Turn off hard disk after-> type in a what time you like in minutes, or "never"
6. Done!

share|improve this answer

According to the Drobo knowledge base:

If your device is in standby mode, any of these situations could be occurring:

  • a loss of connectivity to the host computer
  • a loose data cable to the host computer
  • the host computer is in sleep mode

From your question, it appears that the second and third possibilities don't apply. The first one may not seem to apply at first, but loss of connectivity between the external drive and the host computer can occur in several ways. The most likely cause is that Windows is shutting off the USB interface to which the Drobo is connected. Each USB port has its own independent settings for power management. Go to the Device Manager and check the settings for the USB port your drive is connected to. If you don't know which port it is, check (and possibly change) all of them.

  1. Press the Windows key + R.
  2. Type compmgmt.msc and press Enter.
  3. Click on Device Manager.
  4. Scroll down to USB devices.
  5. Right click on each USB Root Hub device and select Properties.
  6. Go to the Power Management tab and disable everything.
share|improve this answer
    
Thanks, very good reply. But everything is already disabled. –  EtienneT Apr 13 '11 at 17:35
    
@Etienne: so you turned off the power management options in the Device Manager? You only mentioned 'hard drive sleep in the power management settings' in your question. –  boot13 Apr 13 '11 at 22:12

You can use NoSleepHD v2.0. It is a simple program which writes an empty text file every few minutes to your external hard disk drive(s) to keep it from going into auto-sleep mode.

http://nosleephd.codeplex.com/

share|improve this answer

I had to write me a custom program to keep my drive awake: http://zababov.blogspot.com/2011/04/turn-off-hard-disk-power-saving.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.