Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I stop Windows 7 from changing the path of a shortcut to a mapped drive if the drive shows as disconnected? I have cases where I need to map a drive to a folder on the same machine. For some reason when I reboot or start that machine, the mapped drive doesn't reconnect until I double click on it in explorer or "my computer". If the user tries to open that program from a shortcut on the desktop, Windows sees that the mapped drive isn't available and then says "oh wait! I see what you want on c:\share.... I'll change my settings to that" I want to stop it from doing that and keeping the original settings.

share|improve this question

Have you tried making the shortcut read-only? I haven't tested it myself but I think it might work.

[Edit]When you double click a network drive to reconnect it, are you prompted for a password? Did you definitely click the "Reconnect at logon" option when you mapped the drive?[/Edit]

share|improve this answer
    
Hi James. Good idea but that didn't work either. – JimDel Apr 14 '11 at 16:13
    
When you double click a network drive to reconnect it, are you prompted for a password? Did you definitely click the "Reconnect at logon" option when you mapped the drive? – James Apr 15 '11 at 9:54
    
Yep, Reconnect at logon is definitely checked. And no, there is no prompt for a password. – JimDel Apr 15 '11 at 14:26
up vote 1 down vote accepted

It seems that installing SP1 for Windows 7 stopped the problem.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .