Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I attend a Webex meeting, after only a few minutes in, Windows determines that my performance is too low and disables Aero. This is not an issue with Webex. It's an issue with Windows determining that I do not have enough resources.

I have plenty of resources: 8GB of RAM and my CPU usage never rises above 30%. I'm less concerned about how Windows determines whether I have enough resources and more concerned about how to stop Windows from doing that. If I determine that my machine doesn't have enough resources, I will disable Aero.

Is there a way to prevent Windows from disabling Aero based on available resources? I know that Aero gets disabled when an Aero-incompatible program runs, but that's not the issue in this case. I've checked Power Options, but none of those settings apply. Thanks.

Update

Joe Internet makes a good point about GPU resources. I have 512MB of dedicated video memory, which is well beyond the Aero hardware requirements.

share|improve this question
3  
8Gb of RAM 7 low CPU usage don't mean anything if you have a lower performance GPU. Upgrade your video card and Windows won't shut off Aero. –  Joe Internet Apr 13 '11 at 21:48
    
Are you running a laptop off battery power? It could be that enabling Aero would draw too much power and seriously limit the battery life. –  ChrisF Apr 14 '11 at 16:39
    
@Chris. No battery. This is a desktop machine. –  Jordan Apr 14 '11 at 17:02
1  
The amount of dedicated video memory is not the only factor that determines video performance. Start with your Windows Experience Index for graphics, use GPU-Z to determine your actual video hardware, do some googling, and go from there. But generally speaking, if Windows 7 keeps automatically disabling Aero, it's because your video hardware can't keep up. –  Joe Internet Apr 14 '11 at 19:13
    
Regardless of any GPU issues (Windows Experience Index is total bull in my opinion) it doesn't look like there is no answer to my actually question. Thanks though. –  Jordan Apr 14 '11 at 19:57

5 Answers 5

Jordan, what model of graphics card are you using, and what version(s) of the drivers have you been on while the problem has been happening?

The design of this site is such that I can't leave any information unless I provide it in the answer box as I don't have 50 reputation yet, but I'm having a similar problem with a VERY powerful system.

I don't remember the disabling happening for the first year or so I had the PC, which equates to two things in my mind, I hadn't added the 2nd graphics card then, and ATi's drivers were...less mature (not that that's a good thing). I haven't changed anything else about my system in that time, other than updates to common software products.

Specs that matter:

  • 2x HD 5870 in Crossfire (2GB dedicated video memory)
  • i7 920 @ 3.6 GHz on H20
  • 12GB DDR3 @ 1443 MHz
  • Antec CP-850 PSU
  • Windows 7 Professional

I've checked CPU-Z, Hardware Monitor, CoreTemp my voltages and temperatures are near spot on...even my Corsair 750 Professional Gold isn't as close to perfect at load. I want this to be completely software related so badly, but considering I can't reproduce it on a notebook with considerably less power in EVERY way, I'm starting to think it's possibly related to a hardware configuration.

On the software side of things, I'm used to Aero disabling for games/programs that call the service to stop, then re-enable it after. I'm having problems with Aero disabling itself while using something as simple as Mozilla Firefox or VLC video player, which have had no issues in the past.

Drivers, CCC software, all up to date, I've tried with both Windows and ATi software set for both full eye candy and full performance, and I'm getting the same errors. It's odd that I can run a game like Metro 2033 at 5760x1080 with no artifacts, glitches, with Aero still on in the background, then I open one Firefox window or VLC window, and that dreaded yellow exclamation point comes up and I lose Aero immediately.

One thing I found very helpful in my quest to fix this annoyance is this little tidbit. Open your registry, find the following location (you create the Restart Aero and Command folder).

HKEY_CLASSES_ROOT\Directory\Background\shell\Restart Aero\Command

Create a new string in the Command folder, and leave it named (Default), then under Data, type the following:

CMD /C NET STOP UXSMS & NET START UXSMS

That adds the option to Restart Aero to the right click context menu when you're on the desktop. So now instead of opening up a CMD window to re-enable it, you can just right click and click. I created an executable file that just runs the same command as well, but I find this to work even better.

Hopefully this satisfies the answer portion in some way!

share|improve this answer
1  
The design of this site is to focus on questions and answers. As this is an answer posting it as an answer is the correct thing. Also, if you fill out your profile, you should be able to very quickly (5-10 mins) get 100 points, enough to post comments. This is to encourage repeat participation. Your answer appears thorough and well documented. Welcome aboard and may you find this site as engaging as I have. –  music2myear Nov 8 '11 at 21:20
2  
This command required admin rights, so it could be necessary to wrap it with runas –  Eugene Petrenko Apr 23 '13 at 10:38

Throwing this is since I've been suffering from this for awhile now.

I do web development and use four monitors powered by an ATI 6900 and an ATI 6800. In other words, yes, my machine's specs are adequate, and yes, my drivers are up to date.

I keep getting slapped down to the Basic theme on a regular basis. It's annoying enough that I am seriously considering ditching Windows for good.

After searching long and wide for a solution to simply disable the automatic switch to basic theme (seriously MS? why is this not an option?) I resigned that MS simply refused to allow users to do this.

I dug a little deeper.

Since I use Chrome ~95% of the time I'm working, and I noticed that most of the auto theme switching BS was being triggered by a web page making use of CSS3 stuff, I took a gander at:

chrome://flags

There's a handful of items in here not available in the standard settings panel. One of which:

GPU Accelerated SVG and CSS Filters Mac, Windows, Linux, Chrome OS
Use the GPU to accelerate rendering of SVG and CSS filters. 

Hmm... so I gave it a shot and turned it on. The page at http://daneden.me/animate/ (clicking a few of these would cause the theme to switch to basic after about 30 seconds) is my benchmark. I've been clicking buttons on there for 5-10 minutes and I'm not getting the auto theme switch glitch (yet).

So while this is certainly not a solution, it may provide some relief of symptoms and additional insight in case someone out there is talented enough to fix MS's bugs for them.

share|improve this answer
    
I had this problem. I turned the theme back to Aero. I went the page you linked to. I open 7 different tabs, across three Chrome windows. I then wrote a script to scroll through the choices at a 1 second interval, making sure that each animation triggered - this across 7 windows - I couldn't get Windows to switch me back to basic or even complain. Weird. –  user1167442 Feb 11 at 17:06

Try to first reinstalling the drivers and use Windows Update to fully update your system.

You can also try using this tiny program and click on "restore Aero function":

If not, would it be possible for you to post your GPU specs, because there may be some compatibility issues you are not aware of that conflict with Aero.

share|improve this answer
    
Thanks for the suggestion, but it didn't work. It only restores Aero if it has been disabled by a malicious program. What I'm really looking for is a way to always enable Aero, regardless of available resources. –  Jordan Jan 3 '12 at 17:53
    
FYI if you're going to download said tiny program, watch out for adware installs. Between the CNET installer and the app installer I had to decline about 5. –  Matt Lyons Apr 27 '13 at 1:48

It is a bug in WebEx (see http://lonesysadmin.net/2010/01/15/webex-aero/).

I have had the same trouble with Teamviewer and they put an option in to prevent this if you are hosting a session and the session is configured for automatic quality (http://en.kioskea.net/faq/30490-teamviewer-disable-aero-color-scheme-when-using-automatic-quality).

share|improve this answer

Go to Control Panel, then System, then Advanced System Settings. Select the "Advanced" tab then press the "Settings" button in the "Performance" section. Select the "Visual Effects" tab, then change this setting from "Let Windows Choose What's Best for my Computer" to "Adjust for best appearance".

share|improve this answer
    
My computer is already configured that way. –  Jordan Apr 13 '11 at 19:58
2  
Oh dear. Thought that would fix it, sorry. –  Christi Apr 13 '11 at 20:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.