Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I liked the idea of tabbed browsing when IE7 came out. However, when I press Ctrl+T (new tab) IE opens new tab, and for some time it becomes irresponsible, new tab is displaying “Connecting”. This happens even with default page set do “about:blank”. In fact, this IE7 behavior made me to switch to FireFox and left some of my machines with IE6.

Do you know why this delay occurs?

share|improve this question
1  
Have you tried IE8? –  Loïc Wolff Aug 21 '09 at 9:31
5  
This actually happens to me also and I run IE8 on Windows 7. It's the biggest reason I don't use it. I have no idea why it happens. –  miloshadzic Aug 21 '09 at 9:40
1  
Any reason you still need IE? –  Ivo Flipse Aug 21 '09 at 9:52
1  
I just figured you for an IE hater! –  Breadtruck Aug 21 '09 at 10:20
1  
On Windows 7 with IE8 I have a consistent 1 second pause to create a new tab, really annoying. I have NO add-ons (I never use IE except for sites that require it). –  Chris Thompson Sep 15 '09 at 20:08
show 3 more comments

7 Answers 7

Uncheck the "Automatically detect settings" checkbox in Internet Options -> Connections tab -> LAN settings

share|improve this answer
    
Also, try going to Control Panel -> Internet Options -> click "Settings" near Tabs (where it says Change how webpages are displayed in tabs) -> and then where it says "When a new tab is opened, open:" set it to "A blank page" instead of the "The new tab page". –  ultrasawblade Mar 20 '11 at 16:47
add comment

I would think this delay has to do with ie7(and ie8) using separate threads for tabs and the delay being due to overhead in creating threads especially in single core machines.

share|improve this answer
    
But what is it "connecting" to? I have IE to defaulted to open a blank page for a new tab, yet it still says "connecting" during the delay. –  Wavy Crab Feb 21 '13 at 5:32
add comment

Your problem could be related to your IE addons or also if you have a long restricted sites list (tools -> security -> restricted sites):

Check Microsoft's How to make IE open new tabs faster:

Add-ons are loaded by IE when you open a new browser window or tab. This is usually a quick process, but certain add-ons may cause IE to take a longer time than expected. For example, after installing Skype 4.1, this user (and his father) encountered a slowdown in IE on their computers.

[..]

Examine the performance impact of your add-ons using the Manage Add-ons dialog. Click on Tools - Manage Add-ons, and look at the ‘Load time’ column.

[..]

If you do not want to keep a slow loading add-on around, you can disable it, and it won’t be loaded the next time you open a new window or tab. You can also open Add/Remove Programs and remove IE add-ons that you are not using. This removes the add-on for all users on the computer.

If your problem is not related to your addons, then use this file (from Adding unwanted sites to the Internet Explorer Restricted Zone) to delete all your restricted sites:

http://www.mvps.org/winhelp2002/DelDomains.inf (right-click -> install)

share|improve this answer
    
The first is a very good link, a must-read for every IE8 user, even for those who're not experiencing slow loads. –  Arjan Aug 21 '09 at 14:01
    
I tried to read that link today and I can't get the site to open up. –  Breadtruck Sep 15 '09 at 19:41
    
I have the same new tab delay with IE8 on Windows XP. This is a fresh install, no add-ons, no Flash, nothing. Yet it still has a delay and says "connecting". What is it connecting to anyways? –  Wavy Crab Feb 21 '13 at 5:35
add comment

I don't have that problem with IE7 running on Vista. When I ctrl+t or click empty tab box on toolbar I get a new tab really quick with url of about:blank. Do you get the same behaviour if you click the new tab box at the end of your open tabs on the toolbar? Did you reset all your IE options back to default and try it again?

UPDATE: I do see this problem running IE8 on Windows 7 RTM. If I try to open a new tab using the tab button, Sometimes it works directly and other times it actually takes 30 seconds while IE becomes unresponsive and then I actually get a new browser window. If I right click on a link and select open in new tab, it takes 30 seconds also and then opens a new window. Really wierd!

share|improve this answer
1  
Yes, I did. And again, again. –  smok1 Aug 21 '09 at 9:41
    
Check your "Connections" tab under Internet Options and see if you have something like Automatic Configuration turned on or it is trying to dial a connection ( I had a VPN that it would try and fire up first even though I didn't need it ). My similiar problem went away after I changed it to "never dial a connection" –  Breadtruck Aug 21 '09 at 9:51
add comment

Try starting IE with extensions/addons disabled:

Run>iexplore -extoff

Do you have spybot installed on the machines?

share|improve this answer
    
Yes, I have SPybot S&D installed. –  smok1 Aug 21 '09 at 13:50
add comment

To know for sure what it is connecting to, you could use a packet sniffer like Wireshark, or (a bit easier to use I guess) a debugging proxy such as Fiddler.

(By the way: Firefox, not FireFox -- just one uppercase F.)

share|improve this answer
add comment

Is this being caused by any Anti-virus or Spyware monitoring software?

share|improve this answer
    
I'll check it... –  smok1 Aug 21 '09 at 9:40
    
Or, I guess more likely: being caused by some malware itself (like some so-called search add-on that replaces ads?). A good scan may surely help. (Or look into Options and then somewhere find the installed "objects" or something like that.) –  Arjan Aug 21 '09 at 10:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.