Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer is behaving as if the shift key is depressed, but letters still come out lowercase. For example, if I click somewhere in text, it shift-selects the entire text to wherever I click. Numbers come out like %^&&*. When I click icons on the desktop, it shift-selects the icons. Clicking on a program on the taskbar opens up a new instance of the program instead of the window that's already open (I never knew shift clicking on the taskbar did that until this wonderful little issue).

I tried restarting with and without the keyboard plugged in, and it does the same thing. It started doing this randomly while I was working (web development). I also turned off sticky shift keys as someone suggested on a forum, but this doesn't seem to be it. And what is particularly weird is that I am still typing in lowercase letters.

ANY help would be much appreciated!

Update: I gave up and went to format/reinstall Windows, so I was trying to go to the BIOS (to change my boot media to the CD drive) by hitting the DEL key on the boot, but it seems it's not recognizing that key press, which is similar to how it behaves when I'm in Windows. So, what are your thoughts if I have the same problem even before Windows boots, with two different keyboards?

share|improve this question

migrated from stackoverflow.com Apr 13 '11 at 18:40

This question came from our site for professional and enthusiast programmers.

2  
Try a different keyboard. –  William Jackson Apr 13 '11 at 18:43
    
Thanks William, I tried a different keyboard, and same thing. What's weird is that when I restart my computer, regardless of the keyboard, it will work fine for about 10 minutes, and then the problem comes back. It's quite unlike anything I've dealt with, and it seems like such a dumb thing. –  skiindude22 Apr 14 '11 at 6:05
    
Is this a PS/2 or USB keyboard? –  TuxRug Apr 18 '11 at 3:56
    
One of them is a PS/2, one of them is a USB keyboard. I tried them both separately, booting the computer without the other plugged in. –  skiindude22 Apr 18 '11 at 6:29
    
is this a laptop? –  Keltari Aug 15 '11 at 4:50

4 Answers 4

You may want to check you've not accidentally turned on Sticky Keys ("Control Panel" -> "Ease of Access Center" or "Accessibility" (depending on your Windows version), then kick on the option for "Sticky Keys", and make sure it's not turned on).

share|improve this answer
1  
A quick way to see get the Sticky Keys is to press Shift or Ctrl 5 times and it'll ask you. –  Hondalex Apr 13 '11 at 21:52
    
Thank you! However, as I mentioned, I made sure that stick keys was turned off, and it is not behaving 100% like the shift key is pressed, because the letters still come out lowercase. Everything else though, behaves like it would with the shift key held down. Weird right? –  skiindude22 Apr 14 '11 at 6:04
    
Bizarre - I'd recommend installing any keyboard related software/drivers on the machine and seeing if you still have the problem with the MS standard software. If you're not running any, I think you have to look to other programs on your PC. Was anything installed or upgraded at the time of the change? –  Christi Apr 14 '11 at 16:06
    
Thanks Christi! That is good advice. I don't know if this turns it into a hardware problem, but I gave up and went to reinstall Windows, so I was trying to go to the BIOS by hitting the DEL key on the boot, but it seems it's not recognizing that key press, which is similar to how it behaves when I'm in Windows. So, what are your thoughts if I have the same problem even before Windows boots, with two different keyboards? –  skiindude22 Apr 18 '11 at 2:08
    
That's odd. If it were a problem with the port, I'd expect the keyboard to just not work, if it were a problem with the keyboard, I'd expect switching keyboards to fix it. Try booting off a live Linux CD - if the problem exists under Linux, then I think you can conclude it's a problem with the PC itself. The other thing is to double check your keyboard by trying it on another PC and seeing if it still has the same problem. –  Christi Apr 18 '11 at 9:18

This is a software problem, not a hardware problem. I've done this before, though I don't know how, and the easiest way to fix it is by going to the Control Panel, then to the "Ease of Access" or "Accessibility" centre and clicking on "Change How Your Keyboard Works". Once you've made sure that the box next to "Sticky Keys" isn't checked (so Sticky Keys isn't turned on), you then scroll right down to the bottom and click on "Keyboard Settings". In the window that opens, go to the "Buttons" tab at the top and then click "Restore Defaults". Click "Apply", then "OK" and do the same ("Apply", then "OK") in the original window, too. This should fix the problem. It'll override whatever it was that you did to make your keyboard think the shift key was pressed down.

share|improve this answer
    
Wow, that sounds like it could have worked. I wish I had your response a year ago! Thanks very much. –  skiindude22 Aug 2 '12 at 6:17
up vote 0 down vote accepted

I replaced my CPU and it fixed the problem. Someone on another forum had a similar problem, and this fixed it for them as well. Very strange behavior. But replacing the CPU fixed it when nothing else would.

share|improve this answer

I had the same problem and the ease of access settings didn't help either.

What I did was just Hold down the SHIFT key for about 10 seconds then everything went back to normal. I don't know what triggered it since I never installed any new software but this did the trick.

Hope it helps someone in the future :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.