Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While installing Digsby (an IM client) I accidentally installed the Babylon toolbar for Firefox. This was one version of Firefox ago and it didn't go away still (I had 3.5, and installed 4 and it still manifests itself).

And yes, I uninstalled the add-on, went to add/remove programs and uninstalled it there, edited about:config, searched for every instance of babylon and resetted the entries that had it and even deleted babylon.xml from Program Files\Mozilla Firefox\searchplugins.

This solved most of my issues with babylon, but as I set my Firefox homepage to be the default (where you get about:home in the address bar) when I search something in the homepage's searchbox it still goes to babylon, for example: http://search.babylon.com/web/something?AF=15000&babsrc=browsersearch.

I can't find where this is set. Does anyone have an idea of how I can get rid of this?

share|improve this question

4 Answers 4

up vote 5 down vote accepted

You can try resetting all of the Firefox preferences to the default settings. According to Firefox's support page:

At the top of the Firefox window, click the Firefox button, go over to the Help menu and select Restart with Add-ons Disabled... Firefox will start up with the Firefox Safe Mode dialog.

For Windows XP, click the Help menu and select Restart with Add-ons Disabled...

1: To reset your user preferences, click to put a check mark by Reset all user preferences to Firefox defaults.

safe mode dialog

2: To apply your changes, click Make Changes and Restart.

Firefox will restart with your settings changed back to the defaults.

share|improve this answer
    
Thanks! that did it, finally! –  Rui Apr 15 '11 at 10:47

I uninstalled Firefox, searched and deleted all references to Babylon in the registry, rebooted and reinstalled Firefox and the problem was solved.
Be advised that all bookmarks, cookies and passwords will be lost.

share|improve this answer

Here is what worked for me. I disabled it in Firefox add-ons (Tools, Add-ons). It would not let me uninstall it, so I closed Firefox and searched my entire c drive for babylon. I came across a folder labeled babylon and deleted it, as well as a .jss file. Once those were deleted I started Firefox again, and it was gone from my add-ons list.

share|improve this answer

If the problem's only in interpreting misspelled URLs, do the following:

  • Delete the babylon file in C:\Program Files\Mozilla\Search Engines
  • Then open Mozilla and type about:config into the address field
  • Filter for "babylon"
  • Replace the babylon-setting in keyword.url with http://www.google.com/search?hl=en&q=
  • Replace the others "search the web (babylon)" with "search the web (google)" and you're good to go.
share|improve this answer

protected by Nifle Apr 22 '12 at 16:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.