Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying out Firefox 4, after living with Chrome for a while. The thing I miss the most is the RSS icon in the URL bar.

By installing RSS Icon In Awesomebar thanks to Lost without my RSS feed button in Firefox 4, I now have an RSS icon where I want it. However, when I click on it, I get

ERROR
The requested URL could not be retrieved

While trying to retrieve the URL: feed://http//superuser.com/feeds/question/261123

The following error was encountered:

    Invalid URL 

Some aspect of the requested URL is incorrect. Possible problems:

    Missing or incorrect access protocol (should be `http://'' or similar)
    Missing hostname
    Illegal double-escape in the URL-Path
    Illegal character in hostname; underscores are not allowed 

Your cache administrator is webmaster.
Generated Thu, 14 Apr 2011 08:50:44 GMT by ******* (squid/2.7.STABLE6) 

How do I make that button subscribe in google reader, similar to Chrome?

share|improve this question

2 Answers 2

Your problem is caused by the proxy server (or web cache) that your web traffic is going through. Since it does not recognize the "feed://" protocol, it rejects your request as invalid.

The only workaround I have found so far is to manually configure the proxy settings in Firefox. Right now you probably have them automatically configured by your system. If you know your proxy information, you can instead manually configure it. Doing so only for http/https/ftp allowed me to access the feed because Firefox then handled the feed:// URL directly (which ended up with it redirecting to http:// like I wanted).

To configure your proxy settings directly, you'll need to go to Edit -> Preferences -> Advanced -> Settings (next to "Connection"). Use manual settings. You'll have to determine the proxy settings that your system is already using.

share|improve this answer

I dont know... but I'm running firefox 4, and when I go down to the bottom of this page and klick message feed it just shows up perfectly...

Now the error you are displaying here allready shows what is wrong: the acces protocol should be http:// while you are trying to get feed://http:// (and that my friend, doesnt work that way)

Now I dont know if you can change any settings, but try and find them, otherwise, just scroll down, They made a nice WORKING button for you, you should use it...

share|improve this answer
    
Thanks for your answer. My question is to solve the sites that don't make a nice working button. And so I don't have to go digging through a page for what could be in the URL bar... –  John Oxley Apr 14 '11 at 12:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.