Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running an rsync command, copying my files from a server to my Windows machine like:

rsync -rt --partial-dir=".rsync" --del rsync://server/a/ a/

Whenever this command creates a directory, it tends to create a directory with crazy ACLs/permissions. For me, it tends to create ten <not inherited> entries, with one deny entry for the user who ran the rsync command, and the others not making much sense, either. This even happens using the --chmod=ugo=rwX option, which a similar thread suggested.

What can I do to prevent rsync from trying to set permissions at all (and just leave the permissions to the ACL inheritance in Windows)?

share|improve this question
up vote 7 down vote accepted

Mount the directory in question with the noacl option, as described in the manual.

(And if you want to know why the mapping of Unix permissions to Windows ACLs is not straightforward, see here.)

share|improve this answer
    
noacl does prevent the crazy permissions, but since it fakes permissions with the "readonly" bit, I get a bunch of weird partial read-only directories. This is an improvement. – palswim Apr 14 '11 at 19:21
    
How about rsync's --no-perms option? – ak2 Apr 15 '11 at 10:04
1  
Actually, it looks like I get that "partial readonly" symptom on any directory (whether rsync created it or not). It appears Windows is saying just that directories have no readonly property. – palswim Apr 15 '11 at 17:47
2  
ak2's answer was very helpful to be, but it took quite a bit of googling to find how to setup the noacl in /etc/fstab properly. I found this link quite helpful. Using noacl fixed my rsync problems - thanks. – miking Dec 7 '11 at 23:11
1  
@miking already gave a nice hint with that link and the noacl option. Didn't work out for me with MobaXterm (portable), as that seems to re-create /etc/fstab on each start. I partially got around that placing mount -c /drives -o binary,posix=0,user,auto,noacl into my .bashrc. "Partially" as this only affects the "Windows drive letters" (and not e.g. /home). – Izzy May 13 '15 at 12:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .