Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my brand new Lenovo W520 (with Sandy Bridge, 2820QM) and with default settings and on battery power, the "Power Manager" status shows that the GPU usage is constant at 100% or larger. Is this usual? The CPU usage goes down to 34% (798 MHz) when the laptop is idle, as expected.

This is also the case when no additional applications are running. If I understand correctly, the GPU in use is the i7 HD Graphics 3000, which is what I see in CPU-Z. It runs at 650 MHz in idle mode, matching the "Graphics Base Frequency" in Intel's CPU specs. In contrast, the CPU clock speed is 2.3 GHz, i.e., 3 times the idle frequency.

Is it expected that the GPU cannot switch down to a lower frequency for saving power? It would be nice if its power usage would go below 100%...

share|improve this question
    
I thought all W-series models had Optimus graphics, which implies dual-GPU? This might make that behave oddly. –  Shinrai Apr 14 '11 at 17:12
    
Right, it also has a Nvidia Quadro M 1000; however, for the case mentioned above it seems disabled. (It does not show up in CPU-Z for the case mentioned above -- when I run a 3D program, it becomes active and I see both GPUs in CPU-Z.) Given that it is disabled, my guess would be that the Nvidia GPU is not directly related to my question, no? –  hrr Apr 14 '11 at 17:42
    
It's odd that it wouldn't show up in CPU-Z; doesn't it show up in Device Manager? And no, it's probably not directly related, but it was worth throwing out there for at least clarity's sake. –  Shinrai Apr 14 '11 at 17:49
    
Both Intel HD Graphics and Nvidia show up in Device Manager > Display Adapters, which I think is expected... –  hrr Apr 14 '11 at 18:13
1  
+1 same on my T520 –  AndreKR May 2 '11 at 17:15

1 Answer 1

Although I do not specifically own a Sandy Bridge board, I recommend you try GPU-z for a more accurate GPU reading.

The next step i recommend is making sure you're up to date on the latest drivers, that generally hits the GPU performance the most.

If you are using Windows 7 or Vista, trying putting yourself onto the "Windows Classic" Theme in Control Panel\All Control Panel Items\Personalization

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.