Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm the only Windows user at my workplace full of Macs. Of course, being the only person with a different setup, I'm often left to do my own IT troubleshooting.

The issue I have is that everyone's computer is accessible via {hostname}.local (eg, foobar.local), but when I type that in, the host can't be resolved.

I've found that if I change the .local part to my "Connection-specific DNS Suffix" then it works:

ping foobar.local            // Ping request could not find host foobar.local

ping foobar.corp.mywork.com  // <-- now works. Resolves to 10.0.10.25

Simply switching to use the full part isn't an option (long story, but just trust me on that one).

So, how do I get Windows to resolve hostname.local addresses?

share|improve this question
1  
You need a Multicast DNS resolver for Windows. I don't know what's available so this isn't an answer, but perhaps this would help as a search term. –  Kevin Reid Apr 15 '11 at 0:05
add comment

1 Answer

up vote 2 down vote accepted

Install Bonjour for Windows, available from Apple. It's now confusingly named "Bonjour Print Services for Windows". It includes a Multicast DNS resolver, which will handle those ".local" addresses.

share|improve this answer
    
This makes ping work but I can't access the computer in Explorer by hostname.local. Maybe that is a whole separate problem. –  Moss Nov 24 '11 at 2:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.