Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using laptop-mode and the ondemand governor. When I do cpufreq-info I get

analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 800 MHz - 2.40 GHz
  available frequency steps: 2.40 GHz, 2.40 GHz, 1.60 GHz, 800 MHz
  available cpufreq governors: ondemand, performance
  current policy: frequency should be within 800 MHz and 960 MHz.
                  The governor "ondemand" may decide which speed to use

                  within this range.

  current CPU frequency is 800 MHz.

I can't bold inside a code block, so:

current policy: frequency should be within 800 MHz and 960 MHz.

I think it has something to do with temperature, because the max speed of the current policy gradually goes down after I boot. I don't think 960MHz is not even a valid freq. I'm on Arch Linux and never noticed this until yesterday after a system upgrade. It's very noticeable because whne the CPU is stuck at 800 MHz... it's very sluggish. I don't see any packages in my update logs that have anything to do with this that I can tell except for a kernel update, but I rolled that back and it's still doing it.

I've looked at some mailing lists like (cpufreq-utils) and googled around and can't find anything exactly like my problem.

What controls that policy and what could be lowering the max on me?

edit: setting the min and max in /etc/conf.d/cpufreq seems to be making it stick at the right values. It used to auto-detect correctly. Welp...

share|improve this question
add comment

1 Answer

Can you give us more details about the type of processor you have ?

Please wait while I am guessing ... hum ... concentrate ... you have an Intel Centrino 2, haven't you ? If that's the case, then I am in the same situation as you are, but with a Ubuntu 8.04.3 LTS, on a Dell Latitude E6400. This appears after the processor has reached a certain temperature level (a little bit above 65°C / 149°F). Everything comes back to normal when the CPU load is very low for about half an hour.

After some investigations across the net, forums, vendor sites, I can't find the smallest clue about the problem's cause. This seems to happen only under Linux, as I can't reproduce it under Windows XP on the very same host.

I am really waiting for your processor type !

Edit: I know time has passed sinced the original report, but I hope to help others with some more informations.

I'm using a docking station and a bigger external flat monitor. Thus I used to close the laptop lid when working which made it more difficult for the CPU to cool down when under heavy load as the built-in keyboard and screen became warmer and warmer.

In fact, this has even become my way to reproduce the problem 100% of the time when I need to check if I've found the solution.

To avoid it to happen too often, I always let the lid open and sets the max frequency to 1600 Mhz instead of the factory limit of 2400 Mhz. This works for me well enought that the "bug" happen maximum once in each quarter !

Hope this helps...

share|improve this answer
    
Intel® Centrino® 2 with vPro™ technology capable, with Intel Core™2 Extreme or Intel Core™2 Duo processors. –  tladuke Dec 9 '11 at 19:46
    
This was a long time ago. I think the solution was, after days of poking at software stuff, shoot some Duster into the fan on the side of the laptop and after the cloud of dust settled, everything started working right. Not sure how I should mark or edit this thread now... –  tladuke Dec 9 '11 at 19:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.