Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know part of it is to create an extra key in HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones (or more simply, export zone 2 and rename it, such as zone 5)... however, even when I duplicate the Trusted Sites zone (2), any sites I put in the new zone do not work properly, even though they work fine under Trusted Sites. Also, in the Security settings tab, the zone shows up named "Your Computer" (not to be confused with the hidden "My Computer" zone). It has the icon I've set, but the name and description don't seem to be taking.

The registry file I exported/reimported starts as follows:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\11]
@=""
"DisplayName"="My Zone"
"Description"="All your base are belong to us."
"Icon"="inetcpl.cpl#1307"
"CurrentLevel"=dword:00000000
"Flags"=dword:00000043
"1200"=dword:00000000

The icon I've specified shows up, but instead of "My Zone" it says "Your Computer", and where the description should be when the zone is selected, it's just blank below the name.

Am I missing something to make the new zone fully functional, or is IE8 just bugged? While I'm targeting WinXP machines (making some custom web-based tools at work), I have been able to duplicate both these behaviors (zone security settings not applying, and the zone name/etc not showing properly) on IE8/Win7. I was also able to duplicate it on a fresh WinXP/IE6 install in a virtual machine.

share|improve this question
add comment

1 Answer

This page has a wealth of information on this subject. Hopefully it will help anyone doing similar work on this issue.

This page has GPO related information as well.

Based off the first link, Try the following:

  1. Copy an entire zone template (i.e. 0)
  2. Import this as a new zone (try 5) to both hives HKLM and HKCU.
  3. Restart IE.
  4. If the new zone is displayed, change the description, and restart IE again.
share|improve this answer
    
Don't have the same environment available to test in any more (changed jobs, heh)... hopefully I'll get to test this on my home VMs this weekend and see whether it works. –  Doktor J Aug 2 '12 at 21:56
    
@DoktorJ: Any luck? Would hate to waste a bounty :D –  Oliver Salzburg Aug 6 '12 at 13:59
    
Aaand, this doesn't seem to work (using Windows XP Mode, updated to IE8, restarting the VM after applying the registry keys) :( –  Doktor J Aug 6 '12 at 23:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.