Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a computer with Windows 7 Ultimate on it that I may need to reinstall. I set it up a few months ago and had problems which ended up being related to a bad IDE cable (yes, I know, old tech but I had some files I needed on there). I replaced the IDE cable and the install went through without a hitch. I then noticed that it seemed to be sluggish waking from sleep or hibernate. I finally got around to looking at the BIOS settings last night to see if that had a clue for me. Apparently I have my RAM set to a much lower than nominal speed, as well as many other settings that are funny and lower than they should be. However any time I change one of those settings Windows 7 hangs at boot up.

Does anyone have any idea why it might hang? Is it because Windows isn't detecting the new speeds correctly?

share|improve this question
    
Its not a windows problem, its a bios/memory issue, if there is a bios setting to restore defaults, try that. The bios may be clocking the memory back because it is not the correct memory for that motherboard. –  Moab Apr 15 '11 at 15:45
    
As Moab mentioned, try resetting to the fail-safe settings. Windows does not detect such settings, there does not exist such thing as detecting the memory settings to be able to boot your OS. –  Tom Wijsman Apr 15 '11 at 15:49
    
It's currently at the failsafe point. I can try to set the defaults, and see how that goes. –  Joshua Nurczyk Apr 15 '11 at 15:52
    
Be careful checking your RAM speed... most tools (I use Speccy) show the speed that the RAM is running at... not its max speed. For power savings, IIRC, RAM will often be down-clocked when not needed. Fiddling with RAM timings can be a headache. My advice is almost always to set the mobo to auto and leave it be. –  SnOrfus Apr 15 '11 at 17:14
add comment

2 Answers

Those settings are probably low for a reason -- the higher ones cause stability problems such as a hanging/freezing computer (as you're experiencing during boot). The fact that you're using an IDE drive likely adds to the startup delays since the newer SATA technology (and even the older SCSI technology) is far more efficient.

share|improve this answer
    
The settings are at the failsafe point, meaning the absolute slowest setting DDR2 can run at, etc. The memory is rated at a much higher speed, as is the motherboard. the IDE drive does add a few second to the BIOS POST, but that's not the issue I'm talking about at all. –  Joshua Nurczyk Apr 15 '11 at 15:53
    
@Joshua Nurczyk: One of the tricks we used to get a little more life out of failing motherboards back in the days when the 80486 processor was current technology was to slow down the speed of the RAM. My point regarding IDE vs. SATA was that it "adds to the delay." –  Randolf Richardson Apr 15 '11 at 15:57
    
the hardware is barely 6 months old... –  Joshua Nurczyk Apr 15 '11 at 15:59
    
@Joshua Nurczyk: In that case you should consider getting it fixed under warranty if it's not working as documented. –  Randolf Richardson Apr 15 '11 at 16:07
    
Randolf is right. This is a hardware issue of some kind. Windows doesn't care what speed the memory, processor or motherboard runs at, just that they are stable. –  RobM Apr 15 '11 at 16:22
add comment
up vote 0 down vote accepted

Found out the mysterious slowdowns were malware related. Not sure if it was me or my wife that got it. I scanned twice with Malwarebytes and Sophos AV. Malwarebytes updated and then found some stuff that, after removal, the computer is much faster. Not sure why the BIOS settings were bad before, but I checked again and the RAM was running at the set speed again. This is as reported in the BIOS, not in Windows, so it's not an error with some software detecting settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.