Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an XP Pro SP3 laptop, and an XP Home SP3 netbook, both in the same workgroup, and both connected to the same wireless (PC to PC) network (no router involved).

The network is running WEP, as I couldn't get them to connect using WPA or WPA2.

The Windows Firewall is turned off, as Zone Alarm is installed, and Zone Alarm has been configured to allow the newly detected wireless network into the "trusted zone".

I have set the Wireless connections to use manual IP addresses, with subnet masks of 255.255.255.0, and each using the laptop's gateway and DNS addresses, as the laptop is connected to the Internet over USB wireless broadband. The manual IP addresses have been set to 10.1.1.101 & 10.1.1.102.

I can't ping the other PC, on either of the PCs.

Any ideas why?

share|improve this question
1  
If your laptops reveal "(WPA)" or "(WPA2)" next to your wireless network names, then they are capable of supporting those higher levels of encryption. If you can't get WPA2, at least get WPA because running with WEP is not a very secure way to go (it was replaced by WPA then WPA2 for a reason) -- see an open source package called AirSnort if you actually believe that WEP is secure: airsnort.shmoo.com –  Randolf Richardson Apr 15 '11 at 16:43

3 Answers 3

ZoneAlarm is blocking ICMP traffic. I've seen this problem at many sites that have used this product, and in some cases ZoneAlarm had to be removed completely to get "ping" to work again, followed by either re-installing ZoneAlarm or just using Windows built-in firewall (with Service Pack 3 the Windows firewall is actually pretty good compared to previous versions, which comes pretty close to eliminating third-party firewall software, especially if you have a hardware firewall like a LinkSys router sitting between your computer and the internet to block external attacks).

But before uninstalling ZoneAlarm, check through its configuration options for anything to do with ICMP (the underlying protocol used by "ping" and "traceroute" and other similar tools).

A note about software firewalls: Unfortunately, many software firewalls are a little bit like snake-oil in that they alert the users about all sorts of potential threats for traffic that's just normal, and so users tend to start blocking everything like crazy because they think normal ARP requests are potential attacks. It definitely makes the user feel good about having installed the software firewall, even though this could be a false sense of security.

share|improve this answer
    
Both installations of Zone Alarm have the wireless network listed in the trusted zone, which has a medium level of security, and by default, this allows incoming and outgoing ping requests. If I shut down Zone Alarm on both PCs, I still can't ping the other PC, even when the wireless connection is connected, and Windows Firewall remains off. –  Steve Apr 15 '11 at 16:47
    
@Steve: I've seen this before, and had to actually uninstall ZoneAlarm to get this corrected since it was already disabled in the configuration. In a few instances, WinSock was corrupt and had to be repaired as well (and this was only successful while ZoneAlarm was not installed). –  Randolf Richardson Apr 15 '11 at 16:50
    
@Randolf Richardson: I've uninstalled ZoneAlarm, and repaired Winsock, and the problem remains. –  Steve Apr 17 '11 at 2:16
    
@Steve: That's unfortunate because these steps are usually enough to resolve the problem. In the few very rare cases I've encountered where these steps did not resolve the problem I re-installed Windows under the assumption that something subtle yet very important got corrupted in the Windows Registry, a .DLL/.EXE file, or both. If you can't find anything on support.microsoft.com to fix this, and it's not a routing issue, then you may be faced with the same solution (make sure you backup your data before re-installing Windows). =( –  Randolf Richardson Apr 18 '11 at 6:57

Zone alarm could be blocking ICMP echo which will stop the ping, see here for a guide.

share|improve this answer
    
Thanks for including that reference to ZoneAlarm configuration instructions. –  Randolf Richardson Apr 15 '11 at 16:48
    
Those instructions are for Zone Alarm 4 and 7. I have version 9.2.102 (latest version). –  Steve Apr 15 '11 at 17:02

The firewall is the most likely issue. If you don't have anything painstakingly customized in your firewall rules, ZoneAlarm supports "training" mode. Delete the existing ruleset, and place each computer using ZA in training mode, and click "allow" each time you try to do something that it blocks. After a week or so, switch it to normal with exceptions.

Also, depending on your access point, you may want to check to see if it has an isolation feature. Those can block wireless clients from accessing wired clients and vice versa. It's a useful feature in some business settings, but a pain in the butt under most circumstances. In my vizio router, the feature is called "AP isolation" and in many Motorola and Netopia routers, it's called "Wireless isolation". Linksys routers tend to call it "Guest Network". If you find one of those settings, turn it off.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.