Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was able to successfully install and boot into Windows XP Professional x86. I then installed Windows 7 Professional x64. After that, I attempted to boot back into XP and I got a BSOD. From my search on the net, I believe this occurs often, but all the possible solutions have failed so far.

One recommendation was to use the XP disc, boot into Recovery Console, and execute the following commands: fixmbr fixboot bootcfg /rebuild

IIRC, the only one that was successful was fixmbr. Successful, as in it actually could be performed. Both of the others were unable to be performed.

EasyBCD displays the following

enter image description here

Is there anything abnormal according to those settings?

Any recommendations?

share|improve this question
    
Did you change anything in the bios prior to installing W7 and after installing XP? –  Moab Apr 15 '11 at 22:34
    
No. The only thing I changed in the BIOS was the HD (controller?) from SATA to IDE before I even began the partition task. I'm thinking it is something related to the boot loader or MBR, but I am not exceptionally acquainted with either (I only know of them, but I have not actually worked with those files before). –  H3br3wHamm3r81 Apr 15 '11 at 22:36
    
That is why you got the BSOD, changing this setting will cause that, you need to install both OS's with the same Sata bios setting, or revert the setting back to ide. –  Moab Apr 15 '11 at 23:03
    
I installed both OS's with the IDE setting, and I also got the XP BSOD with the IDE setting still selected. Just now I tried to select the AHCI (?) and SATA and then boot each OS, but neither allow the OS's to boot. Before, I was at least booting into W7. –  H3br3wHamm3r81 Apr 15 '11 at 23:24
    
Oh, OK, you still cannot change it after installing XP, With W7 there is a workaround to get it to boot after changing it, but not XP. Not sure what went wrong in your case, I have done many dual boots by installing XP, then W7 without issue. All I can suggest is to start over, wipe the disk completely of all partitions before you start. –  Moab Apr 15 '11 at 23:36
show 5 more comments

2 Answers 2

It may be something with the Windows 7 bootloader, why don't you just use the Windows XP bootloader and modify it to have Windows 7 as first boot?

share|improve this answer
add comment

If you don't need a windows environment, may I suggest that you just use windows xp mode to run the software that doesn't work on win 7?

If you do need the environment, you can very easily create an XP machine in virtualbox without having to dual boot.

Unless you have a specific need to dual boot that xp mode doesn't fill, virtualization is often the answer.

share|improve this answer
    
Yup, I need XP because I have to access the Recovery Console which is not possible in Virtual Machine/ Virtual Mode. –  H3br3wHamm3r81 Apr 15 '11 at 23:50
    
@user7625: Is it recovery console functionality that you have to work with or just a method to backtrack/restore previous state(s)? You can always use VM checkpoints. –  SnOrfus Apr 16 '11 at 0:12
    
Yeah, I need the Recovery Console for classwork, and I also like the idea of having XP on its own dedicated partition. –  H3br3wHamm3r81 Apr 16 '11 at 0:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.