Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My home internet runs through a Sprint mobile broadband card attached to a Cradlepoint CTR350 router. For a few weeks now, it has been behaving oddly - after about 5-10 minutes of being connected (whether I load pages or not), the connection just dies. It's still connected to the router (with good signal strength), but all Internet connections time out, and the wireless activity indicator stays black. For some reason, XP's "repair connection" wizard fixes it, but then it just quits again after another 5 minutes. When it is working, pages load quickly, so I don't think it's having a problem connecting to Sprint. I also don't think it's a problem with my laptop, as another (desktop) computer has recently started having this problem too. The xbox connected by ethernet has never had this issue, though.

Does anyone have any idea why this would happen?

Edit: Now that I use Linux, I discovered that the problem is almost certainly related to DHCP. The connection to the router always works, but sending DHCP requests usually times out. It's not sporadic, either; when it starts failing it doesn't recover without unplugging the router and plugging it back in. This provides further evidence that it's not a problem with the Sprint card, but rather a design flaw in the router itself.

Unfortunately, the seemingly random timing of the failures makes testing difficult -- when I make a change, it's a while before I can know if it truly worked. I'm looking at the following settings for potential solutions: (I'll post results if one of them works)

  • Connect Mode = 3G Only (in Modem -> Settings)
  • Global Reset Settings (in Modem -> Settings)
  • Update Method = Manual (in Modem -> GPS)
  • Disable Failover (in Advanced -> Failover)
share|improve this question
    
Is the firmware up to date on this router? –  Stephanie Jul 11 '11 at 9:21
    
Yes, that was one of the first things we checked. –  nkorth Jul 11 '11 at 13:26
add comment

2 Answers

up vote 1 down vote accepted

I spent two hours on the phone with CradlePoint tech support to no avail. He was very patient and helpful, but found no solution. After getting off the phone I attempted some trial and error playing with some settings. I found that the issue is found under the Failback Configuration settings. Here is how to change it:

  • Open the Router admin page

  • Top left under the cradlepoint name click basic mode, this should switch you to advanced mode

  • Click the internet tab (between network settings *system settings* and go to connection manager in the drop-down box

  • Click on modem under the WAN interfaces heading and then click the Edit button located above

  • The general settings tab should be selected already when the box pops up

  • Scroll down to Failback Configuration and click the drop-down arrow located to the right

  • In the Failback Mode box, click the drop-down arrow and select Disabled

  • Now submit and hit OK after the pop up tells you the settings have been saved

EUREKA!!!

Now go enjoy the internet for longer than 90 second intervals.

share|improve this answer
    
I use the Ethernet port for LAN, so I don't think this is the issue. Right now, we're checking if setting "3G Only" in Modem->Settings fixes it -- if that doesn't work, I'll try this. –  nkorth Feb 12 '12 at 19:40
add comment

update:

After playing around with some settings i have discovered that it isnt exactly necessary to disable your failback. If your follow the steps in the previous answer that navigate you to the WAN interfaces list under "internet connections" you can click on the "up" arrow button next to the active connection. (in my case its the modem) The active connection has a green dot next to it, while the inactive ones have a red dot. This list of connections in order of Failback priority. Therefore if your active connection isnt at the top of the list then the Failback will attempt to find a better connection through one of the connection types listed above it. If you move your active connection to the top of the list this action should also prevent the failback from dropping your signal to find a better one, bc you are telling the router that the most common connection type you utilize is the priority connection. If you have more than one connection type plugged into your router, simply put the best connection at the top of this list, with secondary ones listed under it in order of the best connection speed.

share|improve this answer
    
For future reference, you can edit your original post or add updates in the comments rather than adding another post. –  goblinbox Feb 9 '12 at 19:30
    
Thanks...I wrote that one as a new community wiki in case someone wanted to edit it like they did my other one. Im still a rookie to this site, but Im loving it. –  digitalbilly Feb 10 '12 at 7:21
    
I'm glad you're enjoying the links I sent you! Hopefully the OP will accept your original answer. –  goblinbox Feb 10 '12 at 17:38
    
Sorry for kinda abandoning this question for a while; I've concluded that our router just sucks. I'll accept the answer because it at least helped a little. (I won't be buying Cradlepoint again!) –  nkorth Aug 13 '12 at 14:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.