Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't use gmail or Google log-in enabled openAuth from my browser in Ubuntu, but the same computer (It is a dual boot) works fine for everything in Windows. I connect through a Dynex router, and a Clear Wireless modem.

The web works fine otherwise in Ubuntu. I tried resetting the router, clearing cache, etc., and the problem has continued for a while. It seems I can try to log in, but I can never get to my email or use openAuth (the only two services I tried), it just gets stuck on a blank page. I strongly suspect that I am getting timeouts during https data transfer.

Is there a way to troubleshoot this? I have little knowledge of network administration, but I thought if I could keep a log of the actual data transfer occuring, I could compare what is happening in Ubuntu vs. Windows.

For example, is it a DNS problem that I can't find the https server, or is it that the data packets take too long, or is it that there is something wrong with the authorisation somehow. Is it possible to record these events? How could I go about finding out why this is happening? Also, my Ubuntu browsers work fine on my work network.

share|improve this question
add comment

1 Answer

I dug deeper, and the problem was that my router wasn't giving me the correct IP address from the DNS. Switching to OpenDNS or Google's DNS servers solved it. The sort of tool I was looking for would be wireshark, however I solved the problem before I saw wireshark.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.