Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I honestly cannot understand what I've done over the past few hours or so but the Option key has suddenly just....stopped working how it should

Basically, UK versions of the MBP don't have a the hash/pound symbol explicitly displayed on the keyboard. To get it we simply press Option + 3 and it will print the symbol into your input field

except this has suddenly stopped working and I'm struggling to understand why. Options keys 1 - 5 no longer appear to do anything, whereas 6-0 and all the other character modifiers do appear to be working

Interestingly, I restarted the machine and I could type the symbols into the Login box fine, but after logging in it's stopped working again so I'm guessing I've somehow changed some user setting.

Can anyone help?

share|improve this question

3 Answers 3

Check your keyboard layout in System Preferences (Language & Text).

Check the list of applications started when logging in (Accounts preference pane). It sounds like some third party hotkey utility/application launcher.

share|improve this answer
    
keyboard is set to british. Applications are GrowlHelperApp,iTunesHelper,Alfred,Dropbox –  djhworld Apr 16 '11 at 21:50
    
@djhworld Quit Alfred, press the keys. Does it work again? –  Daniel Beck Apr 16 '11 at 21:56
    
Nope, no change. It just appears to be Option + 1 - 4 that are affected. 3 is the key where the hash symbol should render –  djhworld Apr 16 '11 at 21:59
    
@djhworld Are any other applications running in the Dock or the menu bar? Check the keyboard shortcuts assignments in the Keyboard preference pane. Create another user account (or use an existing one) and check to see if it works when logged in there. Did you install KeyRemapForMacbook (it's not just for Macbooks) or something like that? –  Daniel Beck Apr 16 '11 at 22:03
    
Quit all applications in dock - problem still exists –  djhworld Apr 16 '11 at 22:07

I've asked elsewhere on the Apple discussion forums and they were equally stumped by this

The only 'solution' (as such) was to delete ALL .plist files under ~/Home/Library/Preferences

While it's not an ideal solution, it definitely got my keys working again

share|improve this answer
    
Have you really done this already? Resetting all your applications' preferences? –  Daniel Beck Apr 17 '11 at 16:44

I fixed this problem by checking Input Sources under System Preferences > Language & Text. I unchecked the box for "Unicode Hex Input" and "Keyboard & Character Viewer." Hope this helps someone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.