Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Internet Explorer 9 on Windows 7 Professional. I have installed the Flash player add-on. But I allow Flash only for specific websites. When I open all other websites there's a message:

This website wants to run the following add-on..

How can I turn off or disable this message?

share|improve this question

migrated from stackoverflow.com Apr 17 '11 at 9:48

This question came from our site for professional and enthusiast programmers.

4 Answers 4

The best solution I've found in IE9 is to click on the silly little gear icon in the upper right corner, then Safety, then ActiveX Filtering. This replaces the obnoxious popup on every page with a small blue "NO" symbol to the right of the address bar.

share|improve this answer

Hi @Thành I'm not a full IE user (Firefox ;)) are you after disabling the message from all sites or disable from all other than allowed?

If you have a peep at Tools & Manage Add-ons and find the Adobe Flash object right click and select more information you can check the details there (remove from all sites / allowed on all sites).

And then perhaps go to Tools and in Security tab in the Active X options diable the setting "Allow previously unused ActiveX controls to run without prompt". Hope you solve it.

share|improve this answer

The best answer is to migrate back to IE8, where the notification is in a thin much less obnoxious line at the top of the screen. Having to always answer this question if you don't want flash on every screen is not acceptable.

share|improve this answer
    
your answer, besides very small, is oppinion based. please try to be more objective. –  Lorenzo Von Matterhorn Mar 13 '13 at 17:51

Open Internet Options, by using Tools in IE or Control Panel, go to the security tab, be sure "Internet" icon is highlighted at the top, if the Default Level button is active, click it to reset settings to default level, then hit OK See if this solves it.

Or you can use the Reset all zones to default level button

Restart IE for changes to take effect.

. enter image description here

share|improve this answer
    
This is not a solution to the problem. What is wanted is a way to make IE9 stop requesting privileges for the sites. NOT to grant privileges. The answer to "how do I get out of saying NO every time" is not "say yes". –  Erik Olson Nov 14 '11 at 16:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.