Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a specific problem, but I think it could be generalized. There is a Debian squeeze system with fluxbox on an ASUS laptop. The xscreensaver is installed, but the daemon doesn't run. Well, I set the darkening delay to 1:00:00 (H:MM:SS) in the $HOME/.xscreensaver, and all the settings are well set (behold the daemon doesn't run!).

But the screen becomes darkened (exactly, to total black) in 10 minutes when no user action is occurring. No matter vlc or anything runs, the darkening happens. Restarting the X doesn't solve this problem.

Where can I get rid of this? Is this a cross-distro issue? At all, I don't think it is a bug, in that case somebody might explored it yet.

share|improve this question

1 Answer 1

You need to start the daemon when you log in to X. If you use a .xsession file in your home directory, you can add xscreensaver & to that file.

If you don't have a .xsession, you probably want to use the instructions in /usr/share/doc/xscreensaver/README.Debian: copy /usr/share/xscreensaver/xscreensaver-daemon.desktop/xscreensaver-daemon.desktop to ~/.config/autostart (to start xscreensaver for your user only) or to /etc/xdg/autostart (to launch it for all users).

The blanking after 10 minutes is the built-in screen saver. I believe xscreensaver will disable it when it starts. When xscreensaver is not involved, you can change the settings of the default screen saver with xset.

share|improve this answer
    
Will try it soon. –  sparky Apr 19 '11 at 11:10
    
Didn't work. Well, I'm trying another solutions on and on. –  sparky Apr 28 '11 at 21:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.