Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had powerline networking working in the morning but its not now. I notice that the ethernet port does not blink at all. Is the wire spoilt? Should the port blink even when there is no internet or LAN connectivity?


I tried plugging directly into another ethernet cable which connects into the router, ... still no light ... isit really spoilt? is there somewhere I can see in Windows to verify? is a usb - ethernet adapter worth? perhaps its better to use wireless thenb wait sometime to build a new pc? my current 1 is abt ... maybe 3 - 4 yrs i think

share|improve this question

When there is no LAN conectivity or internet, no, it does not need to be blinking. If light is steady and on, it should be fine. You might just have some misconfiguration in the router (IP, dns, dhcp, etc)

Did you have a power shortage? two things might have happened if so: Simply the router lost some configuration setting (so, check it all well) , and sometimes I have noticed that powerline devices loose for some hours conectivit,y with one of these events, or when some machine of large power usage got triggered, or if it had a problem. Like as if stuff happening in the internal cables might affect the quality of the signal.

Also check if you changed somehow the cables installation, or where are you plugin now the devices, if you plugged it in a different room, etc (always do directly in the wall, and remember distance can be a factor). If there was some change in that. Have you checked with a laptop using same powerline device?

share|improve this answer
i updated my post, so perhaps its the card? what would u reccomend? – Jiew Meng Apr 18 '11 at 14:37
Well, actually I forgot to mention the step explained by Sandeep. It has that tiny reset button in the device, you will find it. Normally you would press it, then the other device's one, they should then sync. One other thing, it can be a problem with dhcp. The router, I guess is a multi port one, asigns by dhcp an IP to each thing connected. Have you logged into the web interface it has, and check the machines it detects connected to? usually there's an 'status' or the like, listing the machines connected, by its netbios name(ie, 'Mike') and IP.(192.168...) – S.gfx Apr 19 '11 at 7:41
For it to work, you need to have in your Windows network adapter settings to have the local IP in auto asigned, it'll be so by default unless you asigned a fixed IP. The web interface to handle router config, usually is accessed by browsing to or Some times, probs that I had with homeplugs (we're talking about these devices, right?) got solved by rebooting the router, but don't do unless you know it's safe and you know some basics about configuring there.(in case stuff gets reset, depends on the router. Some miss some firewall settings. – S.gfx Apr 19 '11 at 7:46

This happens to me sometimes, it could be something going on in your powerline.

What I usually do is hit the reset button on all adapters to reset them back to factory and then they all usually pick each other up and you have a running powerline again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.