Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A family member of mine has a Windows XP PRO desktop (with Dutch MUI).

Now because he wants to type letters with accents (i.e. chars like à) I've set the keyboard settings to "US-International". This should enable the deadkeys feature for entering international characters. This simply means that when pressing a ' nothing will appear until the next key is pressed. So if you type 'a the letter à will appear. If you type 'w then these cannot be "merged" the two 'w will simply appear.

That's the theory that I've seen in practice work quite a few times ... except this time.

Somehow when you press ' it will show TWO chars: '' immediately after pressing the single '. So when pressing 'a we get (3 chars) ''a instead of the desired (1 char) à .

I've tried setting it back to the normal "US" and then back again to "US International" but that didn't fix the issue.

I've googled and found only one question in a forum with the same problem ... but no answers.

So the question I have is quite simple: How do I get the deadkeys working again because the official setting appears to be broken on this system ?

NOTE: For now we have the workaround of ALT- that is very inconvenient but works.


[2011-05-03] I have absolutely no idea what happened but the problem no longer happens at the end users location.

share|improve this question
    
The instructions you gave worked correctly for me (after a bit of fiddling). One thing to check. If you have more than one keyboard layout per language, make sure the layout you want is the default. Alternatively, delete the layouts you don't want so there's only one. –  Wayne Johnston Apr 17 '11 at 21:05
    
Thanks for the pointer; this isn't the problem. I made sure that there is only one keyboard per language. –  Niels Basjes Apr 18 '11 at 21:37

1 Answer 1

When using the US International layout, if you press the ' key twice then it will generate '' after the second press.

In your case, perhaps the keyboard repeat delay is too short and one press of the ' key is being interpreted as two presses by the operating system.

Using the Keyboard control panel, you can play around with the repeat delay and rate, then type in the test text box to see if this might be the cause.

share|improve this answer
    
Hmmm, interesting. I'll have to check that. Thanks! –  Niels Basjes Apr 18 '11 at 21:38
    
I check this and this was not the problem. –  Niels Basjes May 3 '11 at 14:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.