Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not sure if I set this up properly. I want to start Eclipse CDT on my Ubuntu 8.04 install using X11 through VNC.

When I try to run eclipse through vnc viewer command line using ./eclipse it hangs for a few seconds then fails. No error message is output on the command line.

Is there a startup error log or some place I can look to find out what's happening? Or am I doing this wrong?

Ok I've verified that the problem is eclipse.

Is there some kind of version clash here?

desktop: ubuntu desktop 8.04 lts
kernel: 2.6.24-22-generic
CDT 7.0.2 for Eclipse Helios
jre1.6.0_24

When I do ./eclipse it just hangs for a few seconds and I get no error at all. I also don't know if there is a log file that would store startup errors. Is anyone familiar with this kind of problem?

My eclipse.ini is the default file with the -vm argument added,

-startup
plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.2.R36x_v20101019_1345
-product
org.eclipse.epp.package.cpp.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
/home/shwick/ghostDev/java/jre1.6.0_24/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx384m

I booted into my ubuntu 10 partition on my windows machine, did the exact same thing installing eclipse 3.6 helios with jre 1.6 and eclipse ran fine.

Right now I need to know how to get a description of the error that is occurring even though it is not output to the command line or ubuntu's system log /var/log/messages.

./eclipse just hangs and then returns to the command line

share|improve this question
    
If you want to make edits to your own post, you should log in, rather than submitting them anonymously. –  nhinkle Apr 19 '11 at 0:24

1 Answer 1

up vote 1 down vote accepted

I know it's an old post, but I had the same sort of problem, and have found the error log in Eclipse/configuration/*.log files :

!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Cannot load 64-bit SWT libraries on 32-bit JVM
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:260)
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:240)
    at org.eclipse.swt.internal.C.<clinit>(C.java:21)

In my case I had not installed the x64 version of the JDK on the box.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.