Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want compile Firefox on Debian so I create .mozconfig like:

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/ff-dbg
ac_add_options --enable-application=browser

...and now use this command to compile ( create make ):

 ./configure 

...but I get this error:

configure: error: Library requirements (libnotify >= 0.4) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

...so search in repo:

i   libnotify-bin                  - sends desktop notifications to a notifica
i A libnotify0.4-cil               - CLI library for desktop notifications    
i A libnotify1                     - sends desktop notifications to a notifica
v   libnotify1-gtk2.10             -            

What can I do to get this compiled?

share|improve this question
    
have you installed libnotify1-dev or it's variants? –  Sathya Apr 18 '11 at 7:42
    
Do not use "configure"! That will just break the compiling. –  user124355 Mar 23 '12 at 0:21
add comment

1 Answer

up vote 3 down vote accepted

You have to install the *-dev packages if you want to compile something against a library.

In your case it would be one or more of these:

$ apt-cache search libnotify dev
libnotify-cil-dev - CLI library for desktop notifications
libnotifymm-dev - C++ binding for libnotify (development files)
libnotify-dev - sends desktop notifications to a notification daemon

I have Ubuntu 10.04, your results may vary.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.