Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to setup my local pc to be visible to the WWW. I already use apache/mysql on my local pc - day to day but now i want to make it visible online. My real goal isn't to run a website but just to set it up so i can give my ip to my clients so they can check the progress of the project i'm working for them. It would really ease things up for me.

After quite some stuggle, dealing with Port Forwarding i can see the port i want being forwarded by checking @ http://canyouseeme.org/

But even though it shows the port is forwarded, i still cannot manage to get the page loaded it just times-out (saying the request is taking too long).

At first, i thought maybe the ISP might be blocking the port i needed but that doesn't seem to be the case to me, i tried using multiple ports by changing the Listen Port in my httpd.conf file and also forwarding it through my Router's UI.

I tried disabling Windows Firewall and Router Filewall too but it didn't help at all :( I have a Dynamic IP so it changes everytime my router restarts.

I'm not sure what i could be doing wrong, but for some reason it seems like something is blocking my pc from receiving request? I'm using Windows 7.

Edit:- I forgot to mention my Router Model is *ZXDSL 831II - Its a ZTE router*


My IPCONFIG /ALL Response is all below:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : admin-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 00-1C-C0-C5-51-8B
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::a44e:201f:9e34:1a53%10(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.100(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 234888384
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-0C-7E-E9-00-1C-C0-C5-51-8B

   DNS Servers . . . . . . . . . . . : 119.159.255.37
                                       203.99.163.240
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{E2181546-0396-4C0E-ADBD-BB4739320ED1}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:149b:2c93:8864:8d3d(Pref
erred)
   Link-local IPv6 Address . . . . . : fe80::149b:2c93:8864:8d3d%11(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

Here is my NETSTAT Response:

It shows the server is listening to the port i am using 55222 for apache:

Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    0.0.0.0:135            0.0.0.0:0            
share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

Testing a forwarded port from inside the network doesn't always work and depends greatly on the router. This link gives an explanation of the problem and a few suggested fixes. Mostly either "don't do it" or "allowing 'loop back' connections" in your router config.

In the case of home routers, I have been able to allow this after finding a hidden setting somewhere but it's manufacturer specific.

You might want to check your router's documentation (or provide its identity here) to see if this setting exists for it. Different people call it different things but it often has 'loop' in the name.

share|improve this answer
    
@PriceChild: Sorry i forgot to mention my Router Model is ZXDSL 831II –  Zubair1 Apr 18 '11 at 9:36
    
I tried everything my noobish mind could comprehend, i've been trying to get this to work for about 2-3 years but everytime i gave up in-between, this is the first time i came to the point that it finally started showing some results (which being that it started showing the port as opened) lol - I'm not that good with Networking Stuff. Do you have any idea what that secret setting for my router would be? –  Zubair1 Apr 18 '11 at 9:42
    
I haven't been able to find a manual but i've looked at a similar router here and haven't found the option you require. I'm afraid the answer may just be "its not possible with your router". –  PriceChild Apr 18 '11 at 9:50
1  
This link describes the problem, I'm not making it up! :-) –  PriceChild Apr 18 '11 at 9:54
1  
Don't expect it to. The whole point is that you can't access the forwarded port from within your home network. Your friend should be able to access your server though. –  PriceChild Apr 18 '11 at 10:34
show 10 more comments

I found 2 solutions to my above problem:

1). I can access my own IP using a web-based proxy service like kProxy.com or something similar to that. [tested]

2). It might also be possible to access by just changing my DNS to a third-party DNS something like Google Public DNS or OpenDNS, though i haven't tried this. [untested]

If someone knows or has tested the second solution, please do post.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.