Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A copy of an email I sent to company I bought my PC from last December. Does anyone else have any further suggestions?

Basically yesterday my Internet connection went down, and my diagnosis led to me conclude that the Ethernet port on the motherboard isn't working correctly. I discovered this by the following steps:

1) Attempted to ping my router (no response) 2) Swapped the network cable and repeated step 1. 3) Swapped the router and attempted to ping that. 4) Tested both Router + Network cable with an old laptop. Established a connection without problem. 5) Check the port lights on both Router and Ethernet Port when connecting a cable (neither came on when using my desktop. Router one came on when connecting old laptop). 6) Booted up into Safe Mode with Networking support to ensure only the essential drivers + networking was enable, ensuring no firewalls + potential for spyware etc. Attempted pinging router again (no response).

So far I have had no success communicating via the port. I can ping 127.0.0.1 but I'm not sure whether that is handled internally, or does indeed communicate out via the network card via some loopback or not.

ipconfig yields back a 'Media Disconnected' message. Tried disable+renabling my network card via Device manager which made no difference.

As an additional note I run virus scans with BitDefender weekly (best rated AV app for detecting viruses that I could find) and am confident that the machine has no issue here.

The feedback from the tech support at the company I think is useless. They told me to format my disk and that would solve the problem (there wasn't even a mention of reinstalling windows).

I'm considering using a Ubuntu Live cd just to verify and argue that that is the equivalent of a format, as I'm confident that formatting is not going to help (anyone else any thoughts on this?).

My motherboard is a MSI P31 Neo-F V2.

share|improve this question
2  
Pfft, formatting solves every problem. You're obviously doing something wrong there. –  TheTXI Aug 21 '09 at 14:34
    
Use a Live CD as you are planning. Then if the vendor argues, tell them you will unleash the wrath of the Stackies. –  EBGreen Aug 21 '09 at 14:41
1  
You don't happen to have a spare NIC layin' around... Do you!?! –  Breakthrough Aug 21 '09 at 14:45
    
I don't, but honestly I want it fixing :P I can USB to my modem so I'll do that for now. –  Ian Aug 21 '09 at 14:51
    
Further proof that the average level-I tech support person at $mega-manufacturer is a semi-trained, semi-literate chimp. Ahh, for the good old days when men were men and Support reps provided support. :) –  Adrien Aug 21 '09 at 16:15
add comment

3 Answers 3

up vote 2 down vote accepted

The media disconnected is a giant red flag right there. That's a hardware only message.

You've already outlined most of the steps you can take to isolate the problem, add a few more (which you may have done), and that is all the testing there is.

You've verified the router port was known working, and that cable is known working through the use of a separate system. So, the problem is definitely with the motherboard. Now you just need to eliminate the software side of the motherboard as the issue. Have you pulled the power cord to the system while working on it? As long as there is current going to the PSU, a charge can be maintained that is just enough to keep some junk memory active. I have corrected a vast number of hardware issues with simply pulling the power entirely as opposed to just a shut down. Aside from that, try resetting your BIOS to default. There are settings in the bios that might mess with the network adapter, and default settings should ensure everything is enabled and working as intended. Trouble in the BIOS is a very slim chance, but easy enough to eliminate.

share|improve this answer
    
I haven't tried removing the power completely, shall give that a whirl. Yes I did try a reset of the settings in the BIOS which didn't have any effect. Think my difficulty is convincing the tech support at the company that there is a problem. To even suggest just formatting the disk in my opinion reflects a low levels knowledge of PC systems. –  Ian Aug 21 '09 at 15:52
1  
I would recommend trying to turn it on while it is unplugged. Just to make sure that all of the power is gone. –  Brad Gilbert Aug 21 '09 at 19:00
    
Very impressed, fixed the issue completely. Thanks –  Ian Aug 24 '09 at 8:11
    
One of our Dell Poweredge servers here reported a PCIE slot error earlier this week. Reboot did not clear it, complete removal of power did. So, this will fix more than just NIC issues! –  DHayes Aug 28 '09 at 20:06
    
Just experienced a similar issue, pulling the plug solved the problem, was completely confused before hand. Thanks. –  DavidWhitney Aug 10 '10 at 19:03
add comment

If you want to check if it's a software problem then the ubuntu live cd will certainly do the job. It's probably also worth making sure the ports haven't been disabled in the bios.

share|improve this answer
1  
+1 Have checked that, but certainly a 1st place to look otherwise. –  Ian Aug 21 '09 at 14:48
add comment

I would ignore the tech support!

If safe mode didn't do a thing, I am not sure Linux would, however it is worth bunging in a live disk and try pinging your router (or any website... and assuming DHCP and the other usual stuff is working)

I have seen Ethernet sockets die, but it is usually down to either short circuit / electrical problems or tugging / mis-use (accidental). It may be worth checking that pins are straight and no obvious problems that you can fix yourself.

If nothing above helps and it is still in warranty, I would take it back.

share|improve this answer
    
Is in warranty (though you've got statutory rights in UK anyway). My views were pretty similar, seeing as lights don't work on the port suggests a hardware issue. Opening up cast and tinkering "may" void my warranty, so probably won't do that. –  Ian Aug 21 '09 at 14:49
    
Definitely check the pins. –  Brad Gilbert Aug 21 '09 at 19:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.