Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to configure Synergy on two Windows 7 64-bit machines - one a desktop and the other a laptop. The desktop (the Synergy server) appears to be running and waiting for client connections. I've allowed inbound TCP traffic via port 24800 and outbound on the laptop.

When running the test connection on the laptop I get:

ERROR: failed to connect to server: Timed out ..\cmd\synergy\synergy.cpp,270

I have set the client to use the host's IP address instead of the computer name, as suggested by other search results, but no luck yet. I've also set both to run as administrator.

Synergy says it's quitting with errors and to check the log file but I don't know where this is located. Any help is appreciated.

share|improve this question
    
If you completely (temporarily) disable the firewalls on both systems does it connect? –  Majenko Apr 18 '11 at 18:50

6 Answers 6

I was having the same problem, where I was able to get the client to connect initially, but then it just stopped working. It turns out that I had rebooted my host machine, which re-enabled the firewall. As soon as I disabled the firewall on the server, the client connected immediately.

Not being content with leaving my firewall off all the time on my Windows 7 machine, I added the server executable to the list of applications the firewall lets through and turned it back on. To do this (on Windows 7, at least):

  1. Open Control Panel\System and Security\Windows Firewall.
  2. On the left select "Allow a program or feature through Windows Firewall."
  3. Click on the "Allow another program" button.
  4. Even if Synergy is listed in the list of programs, don't select it. It's the wrong executable.
  5. Instead, click on the Browse button, and navigate to C:\Program Files\Synergy\ and select synergys.exe. Notice the 'S' on the end of the file name. That stands for Server, which is the executable that accepts incoming connections.
  6. After adding that exe you should now have an entry for synergys.exe in your allowed applications list. Put a check in the "Home/Work (Private)" column next to this entry, and click OK. I did not put a check in the "Public" column because my computers are on the same network.

After hitting OK, my client connected immediately. I didn't even have to restart the client or the server. I hope this helps someone get connected. Synergy is a beautiful thing when it works!

share|improve this answer
    
Worked a trat for me two Win 7 64 machines, one desktop other laptop, remember this from old synergy actually. Chrs –  MemeDeveloper Jun 30 '12 at 1:56
    
I already had synergys.exe in my list but a network config change (unrelated) changed my network to private so I needed to change it so it allowed access in private (Win 8 Pro) +1 should be accepted –  Mutmatt Sep 17 '13 at 14:40

Synergy is good, but if you want an effective software KVM try InputDirector. I've found it to a lot more stable and bug free. Even more plug and play is Mouse without Borders from Microsoft.

Mouse without Borders even has file copy and clipboard sharing.

share|improve this answer

You need to make sure there exist both TCP and UDP rules allowing synergys.exe and synergyc.exe

This is how you check and add them if you don't have them:

Windows 7 Start button, type in search bar: Windows Firewall, click on the first search result "Windows Firewall with Advanced Security" On the left Click on "Inbound Rules"

Look for existing rules for synergy.exe and synergyc.exe, you should have two for each, if you navigate to the right, you will see a column called "Protocol", one should have the "TCP" protocol selected, and the other one "UDP" protocol (for both synergy.exe and synergyc.exe).

To create new rules:

  1. On the right Click on "New Rule..."
  2. Select "Program" and click "Next >"
  3. Click browse and navigate to the Synergy installation directory, select whatever .exe you're missing in the rules and click "Next >"
  4. Check mark whatever applies to you (usually just "Private") and click "Next >" give it a name (ie: synergys udp)
  5. Now double click on the rule you just created.
  6. Select the "Protocols and Ports" tab and change the "Protocol type" to TCP or UDP depending on what you're missing, click "OK"
share|improve this answer

Important: I installed 64-bit Synergy. The problem is in the Inbound Rules and the synergys.exe association. Association must be to the 64-bit or 32-bit, whichever you installed.

  1. Open the Control Panel
  2. Go to Windows Firewall and click Advanced Settings then Inbound Rules
  3. Find the entry synergys on the Protocol TCP line
  4. Click Properties then the Programs and Services tab
  5. In Programs, 'This Program:' click Browse and navigate to the Synergy 64 bit installation folder
  6. Select synergys.exe which populates the field with this value:

    %ProgramFiles%\Synergy\synergys.exe
    
  7. Click Apply and OK

My client PC connected right away. Good luck!

share|improve this answer

What you need to do:

  1. On the server, click on "Configure Server..."

  2. Upper right hand corner you will see a monitor, drag it down and drop it next to the other visible monitor.

  3. Double click on the monitor you dragged down, and edit the "Screen Name" to match the screen name of your Client.

  4. Stop and start server and client, and kabum! It will work!

share|improve this answer

If the Synergy server is 'quitting with errors' then it won't be running so the clients will have nothing to connect to.

You should be able to telnet to the server on port 24800 from the client and get a connection. If not, either a firewall is blocking the connection or the Synergy server isn't running.

You should be able to see the log file if you use the 'test' button to run a test on the server instead of running it as a service. This will run it as normal but pop up a window with the log messages in it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.