Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got the following configuration (new ISP):

a). Cable internet 32 MBit/s Download and 2MBit/s upload. The gave me an ARRIS cable modem.

b). I use a internationally unkown small router brand (AVM) - I bought it, didn't get it from my ISP.

c). I use a 8-port Gigabit Switch (TP-Link TL-SG1008D)

d). I use Windows 7 x64 Professional SP1

Now I noticed, that b). seemed to make problems, i.e. dragging down my download speed to a sixth of the full speed! (The only solution I found was: Instead of plugging the cable-modem's LAN-cable in the LAN1-port of the router, I plugged it into the Gigabit-Switch and from there one CAT6-cable into the LAN1 port (now WAN-port) of the router. This works so far for the router. Because I need the WLAN of it for my smartphone or whenever I decide I need to go wireless on my laptop and not by LAN-cable. Now I can't access my Drobo FS, because it is still on the Gigabit-Switch as before (because I bought the switch to support the full speed, which was really necessary) and as the switch seems to be passive and the connection to the router only transfers the internet connectivity, but not the drobo access, i.e. meaning that the drobo dashboard on my PC doesn't show up.)

'edit' A technician was here and checked with my laptop - and it seems it is not my router, but sth. on my laptop! Or the combination of my laptop (got a Gigabit-LAN connection) and the other devices. The LAN-cable to my laptop is plugged into the router, but I tried to plug into the Gigabit-Switch as well. It can only be the laptop, because it worked on the technicians laptop with full download speed even in the pluggin-combination that is "broken" for me!

I deactived my antivirus and Windows Firewall and of course shut down every software that could potentially connect to the internet beforehand. My Windows installation is three weeks old. The only thing could be that I got a malware, I'm currently checking. But against this hypothesis would speak, that the internet runs on full speed, when I exclude my router and surf via my Gigabit-Switch! The technician also checked all cables for connection issues. While they worked fine already anyways...

The traffic shapping has the right limit (32 MBit) and the upload speed funny enough isn't dragged down! And I don't think the speed limit is on the router, it's still a quite recent model (get's constant firmware upgrades, even beta/lab versions!). I could provide the details if necessary.

'edit' addition of TCP-Analyzer results:

« TCP Analyzer Results » Tested on: 04.21.2011 09:48 IP address: Client OS: Windows 7 TCP options string: 020405b40402080a00218e5f0000000001030301 MSS: 1460 MTU: 1500 TCP Window: 5840 (multiple of MSS) RWIN Scaling: 1 bits (2^1=2) Unscaled RWIN : 2920 Recommended RWINs: 64240, 128480, 256960, 513920, 1027840 BDP limit (200ms): 234kbps (29KBytes/s) BDP limit (500ms): 93kbps (12KBytes/s) MTU Discovery: ON TTL: 49 Timestamps: ON SACKs: ON IP ToS: 00000000 (0)

Now the question is: What could cause the dip in download speed on my machine?

I still assume it is the combination of my laptop and the router that isn't working.

What can I do? What should I check for? I know there is an (objective) answer out there...

Thanks in advance!

share|improve this question

I'm going to try and break down your question into parts and hopefully it answers your whole as well.

  1. First the speeds listed may only be theoritical limits not actually what you will be getting try running a speed test.
  2. A router even a gigabit router will bring down network speeds because of the extra processing it takes to inspect the packets and to apply rules. This is all down with software which is slow vs a switch which is hardware based (fast).
  3. To gain access to your Drobo FS from the wireless (i'm assuming), you will need to open the correct ports for that service as the firewall on the router is blocking that communication.
  4. No, from the wireless or from the LAN ports on the router you will not get a full gigabit connection because of the 2nd reason.

So overall you are doing the best for speed for the computers connected to the switch, the ones through the router and the wireless will be slower.

share|improve this answer
Hi digibit, thanks for your answer. To reply: 1). I know that, but we're talking about a drop of about 5/6 and not about 1/30 or so! 3). I actually don't want to access the drobo wireless (I don't think this is possible) but only by LAN. Don't you think my current configuration is wrong? I mean I could access my drobo before, so it is not my firewall rules! (Ports are open. :P) 2)+4) As of my 1st reply I got an issue here. To clarify: The ISP sells the exactly same routers to their customers! It just happens to be it's my own already. So a more detailed view into the issue might be needed... – grunwald2.0 Apr 20 '11 at 8:57
Hi digibit, thanks again. I actually found it might be a software / Windows issue! Just see my edits... – grunwald2.0 Apr 21 '11 at 7:44

I would check to ensure there isn't a port on the router and/or switch that is full of {magic}. I have a port on my switch which is apparently for uplink only even though the docs say it is auto-sensing. A computer plugged into the port will frequently time out and have sub 1mbit speeds on the lan.

Presumably, your router is also a firewall appliance. For that reason, you probably want it to be the first in the chain to the internet.

share|improve this answer
Hi Horatia, thanks for your comments! Actually at the moment my router is the first in the chain, if you don't count the cable modem. ;) Would you recommend searching for firewall settings and deactivate them? PS: I'll now have to update the question with new knowledge, please be sure to check back, thanks! :) – grunwald2.0 Apr 21 '11 at 7:42
i mentioned it because you said you put the modem to the switch to the router. You need to have the cable modem plugged into the WAN port of the router, and one cable from a LAN port of your router to the switch. ALL your LAN devices should be plugged into the switch. – horatio Apr 21 '11 at 13:32
up vote 0 down vote accepted

Ok, actually I solved my own question. It was a new (imho broken) security feature in the new firmware of my router, which I installed right before I changed my ISP! Stupidly, I did activate that and didn't check that out, because I never assumed it could be that setting, even though it is logical. This surfaced as of the technicians different PC, which was basically not yet blocked/regulated by the routers firmware (as you have to manage each MAC address and LAN + WLAN individually...)

I deactivated it and everything works fine now, including Drobo access.

I complained to the manufacturer also, but OK it was my fault using a "beta" firmware...

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .