Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

DivX used to work for me, even if not perfectly, on older releases of Ubuntu up until very recently. I used to be able to play, pause and buffer the stream (but was unable to rewind any portion of the video) with Totem codec and plugins. With installation of Maverick, Totem seems to have stopped working as well. When that ceased working, I removed all Totem files from my computer. I tried using gnome-mplayer and gecko-mediaplayer for Firefox but to no avail.

  • I've tried reinstalling totem, totem-plugins, totem-common and totem-mozilla
  • I ran dpkg-query --list totem-mozilla and got the desired output ii totem-mozilla 2.32.0-0ubuntu Totem Mozilla plugin.
  • I also checked about:plugins and it is enabled there

I'm not sure if this problem is either:

  • due to missing packages that need to be installed or conflicting packages that are already on the machine, or
  • due to the fact that I'm running an x64 version of Maverick with flash64 and java6 (seeing as how both are still in experimental phase).

I would like to keep both flash64 and java6 because they don't seem to be causing problems with anything else other than streaming DivX.

share|improve this question
1  
Could you clarify your question a bit please? It's very hard to tell what you're asking. Improving your spelling, grammar, and formatting would also help make things more clear. Thanks. –  nhinkle Apr 19 '11 at 3:21

2 Answers 2

Seems unlikely due to a missing driver or plugin since I was in the same position and was able to play .vls (streamings) directly in Firefox.

Installed VLC and it works fine.

share|improve this answer
up vote 0 down vote accepted

Sorry for getting back so late but i was finally able to solve this problem for me...

With Ubuntu you need to completely remove Firefox first from your system before reinsatlling plugins to purge any conflicting files left over from previous installations.

1) Removing Firefox and all previously installed plugins through synaptic manager is the easiest way to do so

2) Reinstall Firefox, gecko-mediaplayer and all associated dependencies.

And that is it, divx playback should be working for you. I'm still unable to to seek the track at all, even for the portions of the video already buffered. Not sure, but i think that this is a glitch in divx playback in linux; if anyone has the solution to this little glitch your input would be very much appreciated.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.