Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with my google chrome: When I try to search for a term which starts with a string that I previously searched for, that old search term is automatically used. So, assuming I searched for "foo fighters" last week and today I want to search for "foo", when I press Ctrl-L, type "foo" then my search will be "foo fighters" instead of "foo". Is there a way to disable this behavior?

share|improve this question
    
See also this question, if you are using the Chrome LastPass plugin. –  Patrick M Apr 14 at 0:16

3 Answers 3

From: https://www.google.com/support/chrome/bin/answer.py?hl=en&answer=95656

The prediction service is turned on by default. Follow these steps to turn it off:

  1. Click the wrench icon tools menu on the browser toolbar.
  2. Select Options (Preferences on Mac and Linux; Settings on Chrome OS).
  3. Click the Under the Hood tab.
  4. In the "Privacy" section, deselect the "Use a prediction service to help complete searches and URLs typed in the address bar" checkbox.

Keep in mind that the address bar shows matches from your browsing history, in addition to predictions. If you don't want to see matches from your browsing history, clear your browsing history.

Emphasis added to that last sentence, its important!!

share|improve this answer
1  
Actually, seeing the results from the history isn't bad. It also wouldn't be a problem to /see/ the prediction results, just not have them used automatically when pressing return :) This worked for me, thanks –  c089 Apr 24 '11 at 10:50
    
Awesomesauce, glad it worked for you :-) drools at the imminent +100 bounty –  PriceChild Apr 24 '11 at 14:46
    
@PriceChild: Not unless Chris Neuroth presses the Bounty button ... –  harrymc Apr 25 '11 at 17:39
    
Couldn't award the bounty because of a 2 hours block. Now I have a problem: the old behavior is back :( Probably it uses the history now to autocomplete... Will investigate further :/ –  c089 Apr 26 '11 at 7:19
    
Also, I'm pretty sure this only happens on one of my computers, have to check that again. This issue is really weird, I don't really believe (or hope ;)) it's intended behavior... –  c089 Apr 26 '11 at 7:20

I just use "foo", Delete, Enter.

share|improve this answer

I assume you are using the location bar for search. Try the extension "No History". This will stop google chrome from remembering anything you type in there. (Or from displaying it at least).

(You can also always use Preferences | Under the Hood | Clear Browsing Data)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.