Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to know if it's possible to disable the warning you get in Chrome when you try to go to some HTTPS site that doesn't have a trusted certificate.

I have a few sites in my bookmarks that use HTTPS but none of them have trusted certificates, so each time I visit them I manually have to click "Proceed anyway" in the warning and it's getting kind of annoying.

Is there any way to disable the warning or somehow add these sites to some kind of safe list?

share|improve this question
    
Just in case, check your device date/time settings –  Timo Huovinen Sep 12 '13 at 20:23

7 Answers 7

up vote 15 down vote accepted

sippa,
When you use Chrome's Options > Manage Certificates > Import where are you placing the certificate? On the "Certificate Store" screen of the import, choose "Place all certificates in the following store" and browse for "Trusted Root Certification Authorities." Restart Chrome. This normally works for me.

share|improve this answer
    
Thanks! It works now when I imported to Trusted Root Certification Authorities like you said. I do hope they make it easier/faster to add sites to a safelist though. –  sippa Sep 16 '09 at 14:11
    
Google's "Manager Certificates" screen is a wrapper around Window's Certificate Manager (certmgr.msc). Both expose the same underlying concept: if you want to trust an untrusted certificate, you trust it by added it to the trusted store. –  Ian Boyd Jun 2 '10 at 14:02
2  
doesn't work in Chromium 11.0.696.71 (86024) on Ubuntu 11.04 :( –  Radu Maris Jun 10 '11 at 13:58
    
These is now found by clicking "THree lines icon in upper right->Settings->Search box in upper right type "certi"->Manage Certificates... –  AaronLS Oct 11 '12 at 21:45
11  
Chrome asks me for a certificate's password: "Please enter the password that was used to encrypt this certificate file" –  kachar Jun 3 '13 at 12:51

You can avoid the message for trusted sites by installing the certificate.

This can be done by clicking on the warning icon in the address bar, then click

"Certificate Information" -> Details Tab -> Copy to file

Save the certificate, then double click on the certificate file. On the certificate window that opens, click install certificate, then walk through the install.

The next time you go to the site it should work fine without errors.

share|improve this answer
    
Hmm.. I've tried what you said on two sites but it doesn't seem to be working. Do you think I have to reboot after I installed the certificate? –  sippa Aug 21 '09 at 16:13
2  
I also tried go into Options in Chrome and then Manage Certificates and import them that way. It says imported successfully but it doesn't show up in the list. –  sippa Aug 21 '09 at 16:35
    
It's not working –  Abraham Van Helsing Jul 21 at 5:08

For Chrome on OSX, here's a relatively easy way to add the self-signed certificate to the system's Keychain, which is used by Chrome: Google Chrome, Mac OS X and Self-Signed SSL Certificates. No more annoying red warning screen! (I do wish Chromium would simplify adding the exception though.)

share|improve this answer
    
Thank you. If you receive Error 100013 when adding it through Keychain Access, refer to this page: bit.ly/jBujt1 –  Chris Serra Jun 20 '11 at 1:19
    
@ChrisSerra - I'm trying to follow your bitly link but get a 404; can you elaborate on what the instructions there were? –  EmmyS Nov 1 '11 at 16:08
    
@EmmyS: I'm sorry -- I really do not remember. Was trying to find the page in Google Cache, but was not successful. I'll try to review the process again, and see if muscle memory helps me recall the solution. –  Chris Serra Nov 2 '11 at 20:01
    
@ChrisSerra - no big deal; we did figure out how to do it. –  EmmyS Nov 2 '11 at 20:24
    
Thanks for the link. It worked. It seems that the certificate's CN must still match the url's domain even after these steps. Also Step 5 on that site is not needed. It can be added to your login keychain and doesn't need to be in the system keychain. –  mhost Nov 8 '12 at 8:08

Instructions for Linux (Chrome 12+):

Certificate Information -> Details -> Export

Save the certificate as a file of your choice.

Preferences -> Under the hood -> Manage certificates -> Authorities

Import the file and check all the boxes when it asks. You are done.

It is very important to import under the Authorities tab, and not other!

share|improve this answer
2  
The file contained one certificate, which was not imported: xxx.xxxxx.com: Not a Certification Authority. –  kachar Jun 3 '13 at 12:52
    
Well it looks like you dont have authority cert. Try different tab. The question is for authorities... –  lzap Jun 3 '13 at 13:36
1  
Yep, it worked on tab 'Other certificates' –  kachar Jun 4 '13 at 20:37

On OsX you should export your certificate from firefox and import on keychain under the login profile.

share|improve this answer

In order for me to get this to work, I had to copy to file using the "Cryptographic Message Syntax Standard - PKCS #7 Certificates (.P7B)" option and check the "Include all certificates in the certification path if possible" box.

Then I imported using Cornelius' instructions and it worked.

share|improve this answer

If the site to which you go, your own server, make sure that you have installed the Self-Signed certificate or a certificate from a Trusted Authorities on your server. Some server software sets the default test certificate, which can not be added to the Trusted root Authorities certificate store.

share|improve this answer

protected by Diago Dec 15 '10 at 8:45

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.