Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed tomcat 5.5 as a service in my system, but when i open the services using services.msc from the run in window, the Tomcat 5.5 is not available there!! What may be the problem, Any suggestions?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Might sound a bit too simple, but I find myself often in that situation, to discover that I actually have it installed , but is not loaded or running at the moment. Other times, having a load of services in some systems, I don't see it in the list because in some cases is named differently (but Tomcat word is in it, somehow). Anyway, if you keep having issues, at Bitnami.org there is an installer for Tomcat, it might make things easier.

share|improve this answer
    
Yea, your right about it, it is named differently in the service... Thanks....Cheers to you......:) –  tpsharish Apr 21 '11 at 4:35
    
Yep, happened to me a bunch of times! Glad it solved it :) –  S.gfx Apr 21 '11 at 9:21
add comment

You can use SC command to bring it in your service window(mentined as services.msc). For example- Look for Tomcat.exe on you tomcat installation directory. let say the path is as- D:\Tomcat7\bin\tomcat7.exe

And let say your service name is Tomcat7 and display name of your service is Apache Tomcat 7

So your command would be below from your command prompt:

sc Create Tomcat7 binPath= "D:\Tomcat7\bin\tomcat7.exe" DisplayName= "Apache Tomcat 7"

On successful execution of the above command go to service window, refresh it, Now you should be seeing the Tomcat service.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.