Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I started this post but since StackExchange's login system is so strange, I can't seem to log into my account, even using the same exact email and password combo (just treating me as a whole new user). Anyways I'm referencing that post in this new question.

The answer that @Patches gave me was very thorough and helpful, however when I ran the netstat I saw nothing like @Patches described. I saw no tcp/www record on port 80; in fact, my port 80 isn't being used at all! I've modified my httpd.conf several times, changing the Listen directive to all sorts of values: 8080, 8081, 38, 984, etc. and I get the same error (see other post) every single time!!! Here's what my netstat dump looks like:

myUser@myMachine:/etc$ sudo netstat --tcp --udp --listening --program
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address   Foreign Address   State     PID/Program name
tcp        0      0 localhost.localdo:mysql *:*       LISTEN    1188/mysqld     
tcp        0      0 localhost.localdoma:ipp *:*       LISTEN    1115/cupsd      
tcp6       0      0 myMachine:ipp           [::]:*    LISTEN    1115/cupsd      
udp        0      0 *:mdns                  *:*                 888/avahi-daemon: r
udp        0      0 *:bootpc                *:*                 1770/dhclient   
udp        0      0 *:51367                 *:*                 888/avahi-daemon: r
udp6       0      0 [::]:mdns               [::]:*              888/avahi-daemon: r
udp6       0      0 [::]:53539              [::]:*              888/avahi-daemon: r

So as you can see, no lighttpd or anything else listening on 80, 8080, or any of the other ports I mentioned trying.

Please help! About to abandon Linux altogether - on Windows I'd already have PHP and CodeIgniter up and running...

share|improve this question

1 Answer 1

Sorry for delay in looking at this for you - been a busy few days!! Thanks for pasting your httpd.conf, the problem is that you have 2 listen directives. The first one tells apache to listen on port 8080 on ALL ips(because you haven't specified), the second one then tries to get it to listen on port 8080 on 127.0.0.1 but of course this is already being used by the previous directive.

Take the first directive out and Apache will listen only on your localhost address - of course if you want it to listen on more ips then you can add these as well.

Enjoy :)

S

share|improve this answer
    
thanks for the encouragement, here's my httpd; thanks for any help! –  Pam Apr 19 '11 at 10:55
    
Could this be a permissions issue? I installed via Synaptic (possibly "as root"). Even though I am using sudo to start apachectl I wanted to throw this out there because I'm still learning Linux permissions. –  Pam Apr 19 '11 at 10:57
    
@Pam You need to install and run it using sudo, that should be fine. As long as you've installed it from the Ubuntu repositories that's the normal procedure. –  slhck Apr 19 '11 at 12:59
    
@slhck - Thanks for your suggestion, but I have already ruled that out as a culprit. I am starting Apache using sudo apachectl start and am getting the error you see in my original post from yesterday which is linked to up above. –  Pam Apr 19 '11 at 13:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.