Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Microsoft Excel 2007 on a 32-bit Windows 7 install. As of yesterday, when I try to open an Excel file from the desktop/Windows Explorer, Excel starts and displays the error

There was a problem sending the command to the program.

but does not open the file. I can open the file by double-clicking it again.

My searching shows that there are three main causes of this problem:

  1. Ignore other applications that use Dynamic Data Exchange must be unchecked, as described in this SU answer and elsewhere
  2. ZoneAlarm settings may need to be tweaked per this forum post
  3. Compatibility settings need to be disabled, per this SU answer

Ignoring other apps was already unchecked for me, ZoneAlarm is not and never was intalled on my machine, and I wasn't using any compatibility settings. What else could be the problem? The file itself? The file came from another computer, which I trust but don't have access to right at the moment.

share|improve this question
    
Did you ever fix this? I had it and had to go with #1 –  Raystafarian Mar 6 '12 at 20:37
    
No, I didn't. That computer got replaced for other reasons, so I forgot about this. –  Pops Mar 6 '12 at 21:16

2 Answers 2

This is a pretty well known bug in how Windows 7 implements the preview pane in explorer. Go back and look and I bet the preview pane is on. The simple fix is to turn it off. Very few people want it on. Another fix is to alter the user process so that each time Excel is run, a new instance is created. Most people don't work that way but if you open Excel first and THEN browse to the file then you will not see this error. You may see some people mentioning to turn off the DDE feature but this actually breaks copy/paste between instances.

share|improve this answer
    
Wow, I didn't even know Explorer had a "preview pane." I'd seen the button that activates it, but never clicked it. Interesting bug, though. –  Pops May 22 '12 at 0:59

Turning off the Preview Pane (and Details Pane) in the Local Policy Group Editor didn't work for me, still got the error: Start / Run / gpedit.msc

I disabled them anyway, though, because then you can see more in File Explorer.


I found the answer on this page: https://forum.solidworks.com/thread/51794

I know this has been answered already, but there is another way to solve this.

1) rename your sldworks.exe to sldworks_orig.exe 2) double click on a soldiworks file (maybe a .sldprt). It should ask you to select a program. Go ahead and select your renamed file. 3) the file should now open without the error message. 4) rename sldworks_orig.exe back to sldworks.exe 5) repeat steps 2 & 3

You should be good. In short ... you're trying to fix the file type association.

This worked on several computers in my office today. Users where on Win 7 x64 with Solidworks 2011.

NOTE: if you right click on a file and say "OPEN with" and select solidworks and it opens without errors (as apposed to double clicking on a file and getting the send command error), the method I just listed should fix your problem.


Translated to ARTLink6:

1) Go to ... C: \ Program Files \ BERNINA \ ARTlink 6 \ BIN ... and rename your ARTLink.exe to ARTLink_orig.exe or this works too (all one string): ARTLink.exe - With No DDE Error.exe

Kind of confusing: The ARTlink6 program, ARTlink.exe ... uses another name that opens the program: dsgnedit.exe, Wilcom Pty Ltd

2) double click on an .art file. It should ask you to select a program. Go ahead and select your renamed file. 3) the file should now open without the error message.

4) rename ARTLink_orig.exe back to ARTLink.exe . . . No - you get the error message again, leave it as is 5) repeat steps 2 & 3 . . . No

Control Panel \ Default Programs \ Associate a file type or protocol with a program \ Set Dsgnedit.exe as the Default Program for the other Artista file types: .art .art42 .art50 .art60


share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.