Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded my long-standing Windows Vista desktop to Windows 7 over the last weekend, and now I notice my three monitors do not turn off after the stipulated 15 minutes as specified in the Power options. The screens go black like a blank screen saver (even when no screen saver is defined), but it is obvious from the monitors' power buttons they are not put into standby like in the Vista days; remaining blue instead of orange, and the mouse cursor is still around.

The ATI catalyst drivers for my Powercolor Radeon HD5770 PCS+ card (attaching one DisplayPort, two DVI) have been updated but yield no change in behaviour. Any ideas what else I can check to investigate this?

UPDATE 20 Apr

Seems like last night it could standby the displays. I need to further observe this to see if I can figure about a pattern.

UPDATE 21 Apr

It appears that, when i connect to the desktop computer with Remote Desktop, the physical monitors get switched on. They won't get dismissed until i log on to the physical session. So now lies the question of how not to get the monitors to react to a Remote desktop connection.

UPDATE 4 Jul

"Interesting". today i see the main (DisplayPort) monitor going into standby, while the two side monitors remain on. i am totally baffled by Windows 7's behaviour when it comes to deciding which monitor to power down.

share|improve this question
1  
What is the video card you're using? How are the monitors connected? Presumably something is keeping these from sleeping properly, something in software or a driver. –  Shinrai Apr 19 '11 at 15:24
    
As my listing states: Powercolor Radeon HD5770 PCS+ –  icelava Apr 20 '11 at 2:44
1  
That info should be in here. Offsite links are subject to change. Thanks. –  Shinrai Apr 20 '11 at 5:20
add comment

3 Answers 3

Windows tells every monitor connected to wake up when you start using it, either buy moving the mouse or connecting remotely. Why don't you just turn off the monitors that you don't want to be woken up. If they are still plugged in, windows will still generate the images for them, so if you have an extended desktop, you can still drag programs onto screens you cannot actually see.

You could also try and create a batch file that, when run, changes your screen resolution settings to display only the primary monitor. This would mean you remotely connect in, the monitors turn on, you run the script, the secondary monitors get set to unused and they go back to standby. How you would write this script I do not know.

share|improve this answer
    
It wasn't the case for Windows Vista. Also, my primary (centre) monitor is DisplayPort; if i switch off that monitor, Windows/video card will lose knowledge of it and rearrange the desktop layout. That is highly undesirable. –  icelava May 28 '11 at 2:57
add comment

From what it sounds like, this only happens with Remote Desktop. This program seems to be causing problems with your system so there really isn't much you can do. I still have some potential workarounds.

Restart your computer when you end your remote desktop session

This will force your machine to return to a state where there has not been a remote log in. You could try different ways of disconnecting to see if that changes the behavior.

Use a different remote desktop client

Try something like VNC or GoToMyPC and see if that changes the behavior. It could be a bug in the Microsoft product.

Try a different model video card / Change your monitor setup

It is possible that the driver/card has a bug that is causing this problem. I would start by reducing the number of potential variables. Plug in only one monitor and see what happens. If it has no affect, try a different video card and see if anything changes. From there, you can work up to getting all three monitors working.


Hope this helps

share|improve this answer
    
This is a 24x7 computer and restarting after each RDP session would be mentally expensive. i have tried VNC before and found its redraw rate is significantly slower. The ATI drivers have been updated quite a number of times through the months, and I do not feel it is a driver problem as it is a Windows commanding problem. I never saw this happen with Windows Vista before. –  icelava Jul 4 '11 at 6:32
add comment
up vote 0 down vote accepted

I have to say after months and months of driver updates, this problem appears to have vanished (no pun intended). My monitors are able to sleep now; guessing it's a communication problem between Windows 7 and ATI drivers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.