Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My main PC, an 8-year old Dimension 2350, started powering down randomly today (as in monitor says "no signal" and all power is cut, and NOT the progressive Windows shutdown that happens you mistakenly push the power button.)

I'll be looking for obvious issues like loose connections and capacitor bulges/leaks. I think there was a very slight burn smell from the power supply a few days ago, though there's none today and the PC has zero issues turning back on. It will run for 1 to 3 minutes before shutting off and it's supposedly slow, but I couldn't immediatly check what threw it to 100% usage without elevating the Taskmgr. I replaced the previous power supply 3 years ago due to a less hidden smell AND reboots.

I recently noticed prominent lint covering some vents and hadn't bothered fix them then --that DOES increase the CPU temperatures and cause shutdowns AFAIK (Pentium 4 @1.7Ghz by the way). I should run Prime95 stability tests as well. It doesn't have more than the stock heatsink/fan combo for normal cooling and there are no CPU temperature sensors to confirm whether overheating is a problem, but it's been OK at that spot of the house for 3 years. I haven't checked the PCI nVidia card's sensor today but know that particular part is about 50 Celsius on idle and 70 under heavy loads. The card is an 8400GS and the PSU is 350 Watts. The former PSU was rated ~100 Watts back when I had an older nVidia card, so the card should not be choking the power distribution --nothing is even running in 3D when it dies, and heavy 3D games/screensavers haven't been a problem before.

The PC also powered down while I was spying BIOS settings and another time while booting Linux, so I know it's not XP's fault for once and unplugged it till I start checking. I see no "thermal events" nor anything else in the BIOS.

What else might I check? can I finally justify building a custom PC? Thanks

share|improve this question
1  
You don't need justification to build a new custom PC...just money. –  Faken Apr 20 '11 at 0:05
    
+1. That's hilarious, @Faken. Yeah. Now that I think about it, justification is analog to the hole in the wallet after the purchase. Filling it with words doesn't make my wallet any heavier. I might just need to switch to a brandname purchase to lower the costs. –  Vlueboy Apr 20 '11 at 0:19
add comment

3 Answers

up vote 2 down vote accepted

I have had a faulty component, short circuiting internally, making the power supply shut down.

At first I did not know what caused the shutdowns. I figured I would strip the PC down to the bare minimum, so I unplugged most cables (including hdd) from the motherboard, but still no go. Only when I unplugged the power supply from the faulty item would the PC start up again. I checked it with another old desktop and yes, it would not start with the item connected to the power supply.


Due to vibration or expansion/shrinking from heating up and cooling down, perhaps some poorly plugged in connectors or memory modules might start giving bad contact over time; nothing that unplugging+replugging would not solve, though.

Apart from checking loose connections and capacitors, I would also check the connector cables, power plugs+cables and memory, and try grounding the case (and yourself). If none of this helps then either strip down step by step to motherboard only or peripherals only, or strip down first and build up again step by step, to try and detect a faulty component.

share|improve this answer
    
Thanks for the level of detail and sorry for my absense. I have taken the CPU / heatsink off and haven't had a chance to reconnect and test everything. I'll get a new PC this weekend and probably do a last ditch test without even bothering pay $10 for thermal paste to re-attach the old one's parts. –  Vlueboy Apr 21 '11 at 21:44
    
No problem, such hardware failures can be serious time wasters, apart from already being a real pain… –  mousio Apr 21 '11 at 22:03
add comment

in addition to power supply issues, other things that could cause this would be that your RAM needs reseated, or since you mention lint/dust bunnies could be overheating due to lack of airflow.

share|improve this answer
add comment

Check the motherboard for swollen or leaking capacitors.

http://www.badcaps.net/pages.php?vid=5

.

enter image description here

share|improve this answer
    
Thanks for the photos! I didn't actually see leaks or bulges, though it IS a Dell and I had to RMA plenty of those controversial bad-cap motherboards that Dell was sued for years ago. I'm leaning toward overheating, poor ventilation or plain old age. –  Vlueboy Apr 21 '11 at 21:41
    
Some 2350's had the bad caps, some did not. Check to be sure the heatsink is secured down firmly on all 4 corners, some P4's had lousy plastic heatsink retainers that broke easily. Check for fan operation also when cleaning the dust bunnies....cgi.ebay.com/… –  Moab Apr 21 '11 at 22:26
    
Thanks a lot, @Moab. My PC's retainers have very thin metal fasteners that feel flimsier than the plastic fasteners on business Optiplexes. They grip so loosely that my heatsink got freed unintentionally --I hadn't meant to check for CPU damage, but Dell did half the work of detaching the CPU for me :) –  Vlueboy Apr 22 '11 at 19:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.