Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had GNOME DE but recently I've switched to Awesome WM.
The only problem I have I can't set smooth fonts in Gnome-terminal.
If I start gnome-settings-daemon, all the fonts in terminal become smooth, but is it possible to make it work without gnome-settings-daemon?
I would change the terminal if in another smooth fonts were.

My ~/.fonts.conf

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

<!-- Give all fonts light hinting and subpixel smoothing -->
<!--
<match target="font">
    <edit mode="assign" name="rgba">
        <const>rgb</const>
    </edit>
    <edit mode="assign" name="hinting">
        <bool>true</bool>
    </edit>
    <edit mode="assign" name="hintstyle">
        <const>hintslight</const>
    </edit>
    <edit mode="assign" name="antialias">
        <bool>true</bool>
    </edit>
</match>
-->

<!--
     <match target="font">
        <test qual="all" name="rgba"><const>unknown</const></test>
           <edit name="rgba" mode="assign"><const>rgb</const></edit>
     </match>
-->

<!--  Do not smooth Fixedsys  -->
<match target="font">
    <test name="family">
        <string>FixedsysTTF</string>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<!--  Do not smooth Tahoma 8pt and under  -->
<match target="font">
    <test name="family">
        <string>Tahoma</string>
    </test>
    <test compare="less" name="size" qual="any">
        <double>9</double>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<!--  Do not smooth Times New Roman or Courier New for 12pt and under  -->
<match target="font">
    <test name="family">
        <string>Times New Roman</string>
    </test>
    <test compare="less" name="size" qual="any">
        <double>13</double>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<match target="font">
    <test name="family">
        <string>Courier</string>
        <string>Courier New</string>
        <string>Courier 10 Pitch</string>
    </test>
    <test compare="less" name="size" qual="any">
        <double>11</double>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<!-- Do not autohint Courier New, Fixedsys, Tahoma, or Times New Roman -->
<match target="font">
    <test name="family">
        <string>Courier New</string>
        <string>Times New Roman</string>
        <string>Tahoma</string>
        <string>FixedsysTTF</string>
    </test>
    <edit mode="assign" name="hintstyle">
        <const>hintslight</const>
    </edit>
    <edit mode="assign" name="autohint">
        <bool>false</bool>
    </edit>
</match>

<match target="pattern">
            <test qual="any" name="family">
                    <string>Bitstream Vera Sans</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Arial</string>
            </edit>
</match>
    <match target="pattern">
            <test qual="any" name="family">
                    <string>Helvetica</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Arial</string>
            </edit>
</match>
<match target="pattern">
            <test qual="any" name="family">
                    <string>Palatino</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Georgia</string>
            </edit>
</match>
</fontconfig>

~/.gtkrc-2.0

include "/usr/share/themes/Human/gtk-2.0/gtkrc" gtk-can-change-accels = 1

gtk-theme-name = "Human" gtk-icon-theme-name = "Human" gtk-font-name = "Ubuntu 12"

gtk-xft-antialias = 1 gtk-xft-hinting
= 1 gtk-xft-hintstyle = "hintslight" gtk-xft-rgba = "rgb"

~/.Xresorces

Xft.dpi: 96.0
Xft.hinting: true
Xft.hintstyle: hintslight
Xft.antialias: true
Xft.rgba: none
share|improve this question
add comment

2 Answers

Sorry if this sounds flippant, but you could switch to a different terminal (say, the one that comes with XFCE). The reason I suggest this is because, AFAIK, gnome-terminal only takes its settings from gnome-settings-daemon.

Another way of fixing it might be to run xsettingsd: https://code.google.com/p/xsettingsd/

It's supposed to be a drop-in replacement for gnome-settings-daemon. I'm running it, but since I don't really run many GNOME apps, I can't say for sure that it actually works (mostly, I set it up once a long time ago, and, since it doesn't really use that much resources, I just leave it alone).

share|improve this answer
add comment

You can install strace and run strance gnome-settings-daemon.

Check the output and find what gnome-settings-daemon are doing to change the fonts, create a small subset of it in another programming language. DONE!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.