Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a URL in Chrome "local.mysite.com" that autopopulates when I start typing "local.my" into the URL bar.

Note that this URL DOES NOT EXIST in my browser history (at chrome://history/#e=1&p=0) because it isn't a real site and therefore couldn't ever be successfully visited and therefore never shows up in my history.

The URL I want is "local.mysite.com/subdir/". That URL is 3 down in the suggested results because I keep accidentally hitting "enter" when it auto-suggests the unwanted first URL thus reinforcing its assumption that that is the one I want.

How do I get rid of the "local.mysite.com" entry in Chrome's memory?

share|improve this question
    
Here's the same question with an answer: superuser.com/questions/160137/… –  Siim K Apr 20 '11 at 15:16

2 Answers 2

up vote 154 down vote accepted

If you're talking about the address bar, then you can do the following to remove individual items:

  1. Type local.mysite.com
  2. Use the arrow keys to move focus down to the item you wish to delete
  3. On Windows:
    Press Shift + Del

    On OS X:
    Press Fn + Shift + Del

Note: this will only work for items that have the globe icon (Globe icon) next to them.

share|improve this answer

another option is browsing the history tab of Chrome and choosing the menu next to the url you want to delete.

Here goes a screenshot. Sorry since it is in German, but you should get the idea. With the German menu it is the second one "Aus Verlauf entfernen"

enter image description here

share|improve this answer

protected by Community Jun 4 at 18:20

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.