Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an iBook G4 whose wired and airport card aren't leasing a dhcp'd IP address. ifconfig shows that neither interface has an ip address. The DHCP server is known to be good and working properly. Physical network cable works fine with another laptop.

Clicking the 'renew lease' button in the network pane of System Prefs does not have an effect.

I'm presently trying an 'archive and install' of 10.4, but wondered if anyone else had an idea. This issue spontaneously appeared this morning.

share|improve this question
    
archive and install completed, same symptom. Looking for preferences to throw out. –  Dennis Wurster Aug 21 '09 at 18:51
add comment

2 Answers

After bringing the iBook home, I've found that the Airport card does indeed see my home WiFi network. (Great news)

The wired port is still dead. Network Diagnostics says that it was 'unable to connect'.

Pinging the loopback worked fine for IPv4 and IPv6.

The firewall was set to allow all traffic (essentially disabled).

ipconfig getpacket for either interface just returned the command prompt.

It's starting to smell like a hardware issue.

I tried resetting the PRAM just for kicks, but no joy.

I've backed-up all of the data via firewire, and I'm going to try a nuke-n-pave to the drive and a clean OS install to see if that helps.

share|improve this answer
add comment

@Dennis:

Since you were knowledgeable enough to run ifconfig, I've made assumptions about your ability to perform the following actions.

Hardware

Check the Airport card by creating an ad-hoc network on the Mac and then attempting to connect to it from another computer. [Open /Applications/Internet Connect; select Airport; choose 'Create Network' from the dropdown menu.]

Check the wired Ethernet interface either by running a cable directly from the Mac to your Internet gateway or to another computer (Macs automatically adapt wired Ethernet links to suit the connected hardware. That means there's no need to use crossover cables when connecting to other computers without a switch being present.)

Making successful connections eliminates a hardware fault.

Operating System

With the iBook unattached to any network sources, make sure the loopback interface is working (for both IPv4 and IPv6). Using Terminal.app,

 ping -c5 localhost

 ping6 -c5 ::1

Check the integrity of the firewall. Look for entries which could deny access to the DHCP server.

 sudo ipfw list

Try to establish a connection as you normally would, and then see if the Mac has any information about its DHCP status.

 ipconfig getpacket en0

 ipconfig getpacket en1

Barring any apparent faults which you can remedy, post your results here and I'll do my best to interpret them.

Before doing that, however, I recommend you try the Mac's GUI network troubleshooter. You can launch it either via Terminal.app...

  open -a Network\ Diagnostics

...or by changing directories in the Finder to /System/Library/CoreServices and double-clicking on Network Diagnostics, or by opening System Preferences, selecting 'Network,' and clicking on "Assist Me" at the bottom of the preference pane. The application will guide you through the troubleshooting process.

External

Verify that the Mac's Ethernet addresses aren't listed in a MAC address filter in your DHCP server, or, if they are, that any enforced restrictions don't involve DHCP leases. If your router has a persistent firewall, ensure the Mac hasn't been blacklisted.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.