Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I reboot my Mac, the default browser resets itself to Safari (from Firefox). I change it in Safari (as illustrated in this question) but it never sticks past a reboot.

Does anyone have a solution for this? Is there something I could check (a bad permission on a settings file or something)?

share|improve this question
    
+1, I'm seeing this too (I also have Firefox as default) and it's somewhat annoying –  Jonik Aug 10 '09 at 21:47
add comment

3 Answers

up vote 4 down vote accepted

After losing almost my entire afternoon trying to figure out why this was happening, I finally found a workaround.

As Ben said before, this is a bug related to FileVault. When you're using FileVault, your LaunchServices database is not read correctly after a reboot. Since it's where your associations (files and URLs) are stored, they are all reverted to the system default. Deleting and rebuilding your LaunchServices database would not work because your settings are correctly stored, they just aren't read as they were supposed to after a reboot.

Sure, I could disable FileVault, but that's not acceptable for me. I have a lot of sensible data in my MacBook and I live in Brazil, where the risk of having your laptop stolen is quite big. So I needed another way to solve this problem.

Luckily, after browsing a LOT of webpages related to the subject, I found a shell script called "GoodCompany", written by a guy named Martin Kopischke. Quoting his description:

GoodCompany is a shell script (with some accompanying files) to work around the annoying FileVault bug which makes Launch Services ignore user application bindings. If OS X seems to forget your default browser, mailer, RSS reader or editor for certain filetypes after each reboot and you are using FileVault, GoodCompany is for you.

You can download it here. Just uncompress the ZIP file, put it in a folder inside your home and run it with the "enable" action, so it'll be set to run after every login. Read the accompanying documentation for more details.

I just tried it and, although is not exactly a "solution" to the problem, it's a fine workaround. WAY better than disabling FileVault.

share|improve this answer
    
+1 for a thorough answer! Until Apple gets round to fixing the bug, this seems like the best way to go. I also wouldn't want to disable FileVault just because of this. –  Jonik Aug 22 '09 at 9:08
add comment

Are you using FileVault? When I tried FileVault several months ago, I encountered a strange bug where all of my default application settings would return to factory defaults on restart. Everything worked properly after disabling FileVault.

share|improve this answer
    
I am using FileVault; I'll try disabling that when I get a chance. –  Craig Walker Jul 16 '09 at 17:11
add comment

This could be a corrupt prefs file. Try moving ~/Library/Preferences/com.apple.internet*.plist aside and resetting your preferences.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.