Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

All of my desktop shortcut icons on Windows 7 have changed to Notepad icons.

How do I get my old icons back?

share|improve this question
What did you just install? Do you have a virus? What changed on your system? – random Apr 21 '11 at 3:22
Try restoring to a restore point. Seems some spyware attack on your machine. – MoG Apr 21 '11 at 5:18

4 Answers 4

Try this:

Reset the desktop icon cache

  1. Click Start, and open Computer.
  2. On the Tool bar, click Organize and choose Folder and Search Options.
  3. Click the View tab, and check to select the Show hidden files and folders option, and click OK.
  4. Then, enter the following directory:

C:\Users(User Name)\AppData\Local

  1. Find the IconCache.db file, and rename it as IconCache.db.old.
  2. Close the window, and restart the computer.
share|improve this answer

The simplest and quickest way I found is on this forum.

This simply says to delete all the keys for .lnk extension. The procedure is:

  • Press [Win + R] to open run and then type regedit and hit ENTER
  • Go to the HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.lnk folder
  • Remove every subfolder (called keys in regedit) and the keys they contain
  • Now restart the PC

Now everything works fine.

share|improve this answer
Thanks! I didn't need to restart the PC, just restarting explorer worked. – Ismael Jan 20 at 21:55

Download and Run the batch file from this location
Follow the instructions in the command prompt to rebuild the Icon Cache.
Restart your computer to generate a new IconCache.db file.

share|improve this answer

Right click the icon that is appearing in wrong format. (You need to find out the file location that is wrong.) This will help if all your icons have changed to Notepad, Adobe or whatever. The file location will say either .lnk, .exe, .jpeg and so on. This is called a registry error.

Here's how to fix it.

  • Click the start button on the bottom left of the computer screen.
  • Type regedit in the search box.
  • Click yes if it pops up.
  • then go to HKEY_CURRENT_USER
    • Software
    • Microsoft
    • Windows
    • Current Version
    • Explorer
    • File Exts
  • Then, find what extension all your icons are showing up as, whether its .lnk, .exe and double click on it.
  • Right click User Choice then delete it.
  • Click yes.
  • You will need to restart your computer and then all of your icons will be back to normal.
share|improve this answer
Please edit your question to not use ALL CAPITAL LETTERS – DavidPostill Sep 30 '14 at 15:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.