Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to designate a MAC address for MS loopback adapter. Installation is fine. I see in device manager, the adapter and in advanced tab, I enter the mac address I desire. But when I do in cmd prompt ipconfig -all, I see the original mac address is retained.

I did search a bit but google is not extremely useful. I am hoping an easy solution exists to this problem. My os is XP.

thanks, KD

share|improve this question
    
why would you need to change the MAC of the loopback adapter? –  Arctor Apr 21 '11 at 5:02
    
Since there is no medium, there is no MAC address really. Why do you want to change it? Even if windows is silly enough to list a bogus address, you gain nothing by changing it. –  psusi Apr 21 '11 at 13:46
add comment

1 Answer

It seems that the adapter will accept only locally administered MAC addresses as valid (makes sense). This is signified by 7th leftmost bit set to 1, so MAC must start with 02. I changed it without any problems: enter image description here

Ethernet adapter Local Area Connection 3:

    Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : Microsoft Loopback Adapter
    Physical Address. . . . . . . . . : 02-FA-FA-FA-FA-FA
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 10.0.0.1
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :

If you try to define it as Globally unique (00), it treats it as invalid and reverts to default: enter image description here

Ethernet adapter Local Area Connection 3:

    Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : Microsoft Loopback Adapter
    Physical Address. . . . . . . . . : 02-00-4C-4F-4F-50
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 10.0.0.1
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.