Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I set Windows 7's Recycle Bin to automatically have a default disk space allocation for deleted files from external hard drives and TrueCrypt-mounted volumes?

I remember in Windows XP, I can set a percentage of total disk space that will automatically be used as storage capacity for deleted files by the Recycle Bin, and this will be applied to all external HDs or TC-mounted volumes.

Windows 7 defaults to the 'Don't move files to the Recycle Bin. Remove files immediately when deleted' setting for newly mounted external HDs and TC mounted volumes. Since I am expecting deleted files to go to the Recycle Bin, sometimes this causes an 'Oops' when I delete files in external hard drives or TC mounted volumes, as Windows does not move deleted files to the Recycle Bin, but just deletes the files permanently. I have to remember to manually set a custom Recycle Bin storage space for each new drive that is mounted by Windows to avoid this issue.

I only use and mount TrueCrypt file containers, not drives. I also don't mount TrueCrypt file containers as removable drives. ('Mount volume as removable medium' is unchecked in Mount Options.) In my $Recycle.Bin > Properties > Security settings, 'System' and 'Administrators' are already set to 'Full Control', while 'Users' only have 'Special Permissions' checked in gray. There are no other groups. I haven't changed or edited anything in these settings.

I am using Windows 7 Ultimate.

share|improve this question

1 Answer 1

It seems your mounting your external drive with TrueCrypt as an removable drive. This influences the behavior of the Recycle Bin. If the drive is a favorite/system drive you can find the setting in "Organize favorite/system volumes", else there is a setting in the mount-dialog for manual mounted volumes.

If this is not working and you are using Windows 7 Pro/Ent/Ultimate you should check the permissions of the (hidden) "$Recylce.Bin"-folder. The default permissions are:

  • Administrators => Full Control
  • Creator/Owner => Full Control
  • Everyone => Change
  • System => Full Control

Wrong Permissions can result in a deactivated Recycle Bin. You have to change the settings manually in the settings dialog to force Windows to create the folder.

share|improve this answer
    
You mean Windows 7 defaults to the 'Don't move files to the Recycle Bin. Remove files immediately when deleted' setting when deleting files on a removable drive (including external hard drives)? Know how to make them default to what I requested in my question, instead? –  galacticninja Jul 4 '11 at 5:17
    
I only use and mount TrueCrypt file containers, not drives. I also don't mount TrueCrypt file containers as removable drives. ('Mount volume as removable medium' is unchecked in Mount Options.) In my $Recycle.Bin > Properties > Security settings, 'System' and 'Administrators' are already set to 'Full Control', while 'Users' only have 'Special Permissions' checked in gray. There are no other groups. I haven't changed or edited anything in these settings. –  galacticninja Jul 4 '11 at 5:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.