Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have three Windows 2000 machines talking through a hub, and we are trying to upgrade so we bought a Windows 7 machine to add to the network. All of the Win2K machines can access the public directory on the Windows 7 machine, but the Windows 7 machine cannot access the other Win2K machines -- we just keep getting a pop-up asking for network user name and password.

Any suggestions?

share|improve this question
    
See this...ykyuen.wordpress.com/2009/09/04/… –  Moab Apr 21 '11 at 16:42
    
Thank you. This has worked for one of my machines (the Win7 machine can now access one of the Win2K machines) I will try to see what the problem is with the other 2 win2K machines. –  Craft Apr 21 '11 at 17:33
    
The fix listed in the link from Moab has Worked!!! –  Craft Apr 21 '11 at 17:48
    
I made it an answer, you can accept if you wish –  Moab Apr 21 '11 at 19:37

2 Answers 2

Check your Windows Policy Editor for network/security settings. As I recall there's a setting in Windows 7 to allow compatibility with older versions of Windows, but in order to get this you have to lower the security requirements.

If you're behind a firewall, then this isn't a big deal unless the general public are able to connect their laptops to the inside of your network (e.g., your company is a public library).

If you don't have a firewall, then a router such as one of the LinkSys wireless/broadband routers can provide NAT for you, and you should seriously consider getting one of these.

share|improve this answer
    
I have NO experience with Windows 7. We have no firewall. (All computers are connected with ethernet cables to a hub [not a switch]) –  Craft Apr 21 '11 at 17:24
    
Might be better to have a switch, they tend to be more intelligent when it comes to networking, just a thought. –  Moab Apr 21 '11 at 17:39

In Windows 7 Professional and Ultimate:

  1. Open the Administrative Tools in the Control Panel in your Windows 7 (NOT the network drive server)
  2. Open the Local Security Policy
  3. Select the Security Option under Local Policies
  4. Choose Send LM & NTLM responses in Network security: LAN manager authentication level

. enter image description here

.

For Windows 7 Home Users:

you can edit the registry yourself by doing this:

1) open Notepad:

2) copy this text and past in notepad:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa] “lmcompatibilitylevel”=dword:00000002

3) save the file on your desktop (or anywhere else) as name.reg – “.reg” is important.

4) run the file and press yes on the 2 poppups.

Now it should be fixed.

.

Alternate method for Home version

For Windows 7 HOME PREMIUM:

  1. Click “Start” on lower left of screen.

  2. Click “Run” in the menu.

  3. Type regedit then click “Ok”.

  4. User Account Control warning may pop up – click “Yes”

  5. Find folder “HKEY_LOCAL_MACHINE” double click on it

  6. Now on the same left side below the folder you clicked on find “SYSTEM” and double click on it.

  7. Now on the same left side below the folder you clicked on find “CurretControlSet” and double click on it.

  8. Now on the same left side below the folder you clicked on find “CONTROL” and double click on it.

  9. Now on the same left side below the folder you clicked on find “Lsa” and RIGHT CLICK ON THE Lsa folder.

  10. Scroll down to “New” then select “DWORD (32-bit) Value”

  11. The new item appears to the right of the folders you have been clicking on. The name is highlighted as “New Value #1″

Change the name to LMCompatibilityLevel

  1. Now RIGHT click on it “LMCompatibilityLevel” Then select “Modify”

  2. Change the “Value data” from 0 to 1 then click “Ok”

  3. At top right click on “File” then “Exit”

  4. You are finished, and it should work.

.

NOTE: If your network drive host is a Windows 2000 server, you may need to upgrade it to SP4.

.

Source of Information

.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.