Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows NTFS on my local domain. I can mount the share by going to "Places > Connect to a Server." I'd like to permanently mount my share to /mnt/Quartz which is a folder that exists under mnt. I have followed this guide, MountWindowsSharePermanently, but I'm still getting a "wrong fs type, bad option, bad superblock on \\remote\quartz" ... here's what I have setup:

/home/alfie/.smbcredentials:

username=windowsdomain/chum
password=myPassword

/etc/fstab:

//remote/quartz /mnt/quartz cifs credentials=/home/alfie/.smbcredentials

I save, run sudo mount -a, and I get the above error. Since I can mount the share through the GUI fine, I don't think there's a problem with the share. It must be simple, any ideas?

share|improve this question
    
Well, I can confirm that there is nothing wrong with your thinking - I just replicated this locally and it worked. –  Majenko Apr 21 '11 at 17:02
    
Can you confirm that /sbin/mount.cifs exists? –  Majenko Apr 21 '11 at 17:02
    
Installed smbfs again and it worked great! If you want to make your comment an answer I'll mark it as best to give you the rep. –  chum of chance Apr 21 '11 at 17:19
add comment

1 Answer

up vote 3 down vote accepted

You need to make sure that /sbin/mount.cifs exists. Try reinstalling the smbfs package.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.