Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My ISP/Model router is set to 192.168.0.1

My DD-WRT is set to 192.168.0.80. A Linksys WRT300 that was flashed with a DD-WRT.BIN specifically for it (not the generic one).

  • It uses the PPTP connection type
  • DCHP = Y
  • WAN IP and subnet get set by DHCP
  • The Gateway is set to 173.195.0.129

It's editable but no matter what I put in, it gets ignored and is overwritten to the (.129) address. The Gateway PPTP is set to 172.195.0.4.

Any PCs/devices (Apple TV, etc.) that are plugged into that router get an IP address from it, and gets a public US IP address. Works great.

The problem is, any devices (ones that need to have a Canadian public IP) not plugged into that router, you can't connect to it (can't even ping it). Likewise, all the devices plugged into it, can't ping outside of it (not even 192.168.0.1), so there's no connectivity between the two "networks."

I understand why this is happening -- the WAN port is reaching out beyond the ISP, so even though they appear on the same network, they kind of are not.

Can someone help out?

share|improve this question

1 Answer 1

A few things to check come to mind:

  • Make sure you're clicking on the correct "Save" button after changing the Gateway IP

  • Update the firmware (I recall working with a router that didn't save the changes properly for some of its settings, and that this problem was resolved in a newer firmware, which also mentioned this particular fix in the release notes; I wonder if you have the exact same router, heheh)

  • If I'm understanding you correctly, the WAN side is set to acquire its address dynamically via DHCP, and if that's the gateway you need to modify then it's getting updated by DHCP as well and your changes definitely won't take effect (you'll need to switch to Static and enter everything manually in that case, but if you do this make sure your ISP assigns a Static IP to you so that you don't inadvertently cause conflicts with other users or get yourself disconnected unexpectedly)

share|improve this answer
    
The problem is the gateway has to be set to the StrongVPN server - so it can get the US IP address. If I make it 0.1, no US IP. –  David Apr 21 '11 at 19:23
    
@David: Then I suggest you try to rule out the first two points I made, and if that doesn't resolve it for you then you may need to get a Static IP address from your ISP. Did I understand you correctly that you're now in Canada? If so, I can tell you for certain that Shaw definitely provides a real Static IP service (that literally does NOT require the use of a DHCP server for a Permanent IP address assignment), as do many of the smaller ISPs. –  Randolf Richardson Apr 21 '11 at 19:25
    
Hey Randolf. Yes, I am in Canada. I use StrongVPN to get a USA IP address to take advantage of content restricted to the USA. So I need to authenticate to their VPN server via PPTP to get that. The problem is I have to set the gateway of course to their machine, and not my ISP router address. I'm thinking there must be a way to bridge my two LANs within this DD-WRT router. –  David Apr 21 '11 at 19:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.