Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an external hard which is full. My windows 7 shows all of the files and there is no problem, but in Windows XP none of the files are visible (it also shows that the hard is full).

I enabled the "show hidden items" and disabled the "hide protected files" Folder Options, but it doesn't make any difference at all.

Any idea?

share|improve this question
    
Clear your recycle bin first –  random Apr 21 '11 at 20:59
add comment

migrated from serverfault.com Apr 21 '11 at 19:55

This question came from our site for professional system and network administrators.

1 Answer

Get to a DOS prompt (Start Menu -> Run -> Cmd) and type the following commands (I'll assume that drive E: is assigned to your external hard drive):

  • dir E:\ /a
  • exit

If you see files listed there before typing "exit," then there's something odd going on with your Windows installation in that it can't reveal these files to you (a scan for SpyWare or viruses may be in order).

If there are no files listed there, then it may be a compatibility issue (do you have XP patched up to Service Pack 3?), or there is corruption on the disk that Windows 7 can safely ignore (because it's got a newer NTFS code base) while XP is effected.

* VERY IMPORTANT * At any rate, before you change anything on the drive (fixing errors with tools like "chkdsk" requires changing the contents of the drive), make sure you have a backup copy of it all first just in case any of the changes cause it all to be lost.

share|improve this answer
    
Thanx, I found the problem. I don't know what it is but "Show hidden files" option will not stay checked. I had this problem a long time ago but I formated my hard that time ! I don't want to do it this time. Is there a specific antivirus for this? –  AliBZ Apr 21 '11 at 21:21
    
Make sure you're using the "OK" button to save your changes. A lot of folks have become accustomed to clicking the "X" in the top-right corner lately to save their changes and I suspect it's because Apple designs their interfaces this way (the "X" in the top-right corner should behave the same as a "Cancel" button in my strong opinion). –  Randolf Richardson Apr 21 '11 at 21:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.